Memory leak when playing videos from network source

I bought a vero4k, but I have had this issue on the Rpi3 I installed a couple of days ago.
I will start a movie from my NAS (I tried connecting the NAS with NFS or SMB, issue stays the same. The movie will start to play, but if I open top over ssh, the memory usage of kodi starts increasing until it gets killed by the kernel.

I made a debug log:

I have the same problem with kodi 18 on vanilla ubuntu.

That would indicate that it is a Kodi issue and you would have a better chance to open a thread on Kodi forum mentioning the Kodi 18 Ubuntu install.

What is the mediainfo of the video? Does it happen with every file?

Have you tried playing the file from USB? Have you tried fstab based mounts?

I did start a thread on the kodi forum, who asked to do a vanilla install and got no further replies.

On OSMC it happens when connected to USB storage too, it happens mostly on m4v files. But I had mkv files trigger it too.

I tried fstab based mounts

Happens with USB storage on the vanilla kodi18 too…

But not when I put in on the interal disk, which is strange

file info in yatse says: 4:3 SD H.264 AAC 2.0

To be honest if it happens on a Vanilla installation on several platforms the likelihood that your files are problematic is very high.

The files where created by handbrake, I could privately share a problematic one if that would help (offered the same to the kodi support folks)

Well just take one of the public available demos and just reencode it with your handbrake settings and share that.
But to be honest considering the amount of people playing files without issues so there must something wrong with encodes.

1 Like

The thing is that I always use the presets in handbrake and most encoded files do work.
I re-encoded one of those files to mkv with a different video and audio codec, I re-ripped the disc with the same new settings and the problem remains.

Until yesterday, I wanted to debug it further, played the mkv file on kodi 18, it worked. The m4v file worked. It also plays on my osmc now, unmodified.

I hope it stays like this, but it’s one of the weirdest issues I’ve seen.