Menu Item Text & Icons missing after April Update

The recent April Update went well, however I immediately experienced a few issues after rebooting.

The main being missing menu text and icons from MyOSMC and Settings> Interface.

The following menu items are appearing:

  • Music
  • Videos
  • Pictures
  • Games
  • Settings
  • Power

Strange MyOSMC text and icons are not appearing there’s a blank space for the menu item.

If i go into settings, the Interface menu text is not appearing also, but there is a blank space for the menu item.

I have uploaded my log Here

Or visit this link

Sounds similar like this:

Do you have any different font chosen?
Are you using profiles?

I have two profiles and I have tried to chance the font to Aria but it didnt solve the issue.

That’s exactly like mine, that Interface “menu text” is missing.

I managed to get the text display and the MyOSMC icon showing again by doing the following:

Go to Settings > Interface > Skin
From there select Configure Skin > Home > Customise Home Menu

After selecting the last option it will ask you to download the following addons:

  • Skin Shortcuts
  • Skin Helper Service

Once that is done, you’re good to go all menu item text and icons should now appear.

Edit, this was just a temporary fix, after a reboot the issue is back, so sad :frowning:

As far as I understood the situation this only happens if you use several profiles.

As long as this is not fixed, could you try the following workaround:

  • If you are in the situation if missing text of menu items, logout using “power->logoff user” from the main menu.
  • Afterwards re-login, again.
    On my test system this only stays until next restart of the mediacenter and the issue reappears.

I can confirm that using more than one profile triggers this issue. I removed all profiles except the master and now I see all text and it survives a reboot.

I tried a fresh copy of the April image but the problem persisted , I’ve reverted back to the December Update as I’ve experienced a lot of issues.

I’ve just been hit by this bug too. Mighty annoying