Menus are OK but no video or audio

I have been using OSMC with a raspi4 on the same TV and have had no issues until recently. Menus are fine but cannot play videos. At one stage, video WOULD play if I connected the hdmi to HDMI1, however, the TV remote would not work in that situation and had to use the KODI remote app on an iphone. That has since all stopped working.



Wow!! Due to the overwhelming support and feedback here, I managed to find the source of the problem. Thank you so much!

My initial concern was that the TV hdmi controller (an old tv) or the hdmi cables had gone wonky as only video playback would be affected. OSMC menus, tv remote control of said menus were all fine.

In order to test the underlying hardware, I reinstalled Raspian and played a video full screen using good old VLC. It worked.

To bring it to the next level and to test the hdmi fully ie remote control etc, I installed libreELEC and yes, absolutely no issues.

So, there you have it. The problem was OSMC that had sadly become unusable on my raspi 4. Things like that happen; things go wonky. It was time to upgrade.

Glad to hear this is solved for you.

From a look at your logs, your issue was almost certainly caused by changes you made to config.txt.

Eh, nope. Unless, of course, a config.txt can stay untouched after several complete reinstalls and each time with a different version.

Changes like config_hdmi_boost=5 are not standard in the OSMC installation and would have been added by you.

I’m glad you found another solution.

1 Like

I believe you are correct in saying that that config change was not standard but, again, it wasn’t the source of the problem. If you wish to focus on that particular change as a possible cause then as per Pi documentation:


Configures the signal strength of the HDMI interface. The minimum value is 0 and the maximum is 11.

The default value for the original Model B and A is 2. The default value for the Model B+ and all later models is 5.

If you are seeing HDMI issues (speckling, interference) then try 7. Very long HDMI cables may need up to 11, but values this high should not be used unless absolutely necessary.

This option is ignored on the Raspberry Pi 4.

As I WAS seeing hdmi issues, I needed to troubleshoot them. The change itself, which may have been a relic of previous cable issues, did not fix nor worsen the current problem and this was further proven by, as mentioned, complete fresh installations using various releases namely OSMC_TGT_rbp4_20211225.img.gz, OSMC_TGT_rbp4_20221101.img.gz, OSMC_TGT_rbp4_20220824.img.gz. Whether these releases worked or not under normal circumstances wasn’t a huge concern. The main point was to see if the symptoms would change depending on which version I was using and they did. With the new installations, default config files were untouched.

Did you test those with a complete stock install or with restored Kodi userdata?

It does not matter, the user is happy with his current solution.

If he wants to use OSMC in the future, we can advise.


I would presume that writing a new image would clean an sd card and wipe all customized files. No subsequent customization was done after installation.

It would, which makes your situation all the more baffling. The only rational I can think of for a stock RPi 4 OSMC image to not work on a stock RPi 4 would be a hardware fault of some sort. However, why this would affect OSMC and not LE would seemingly defy logic. Best of luck. Sorry we couldn’t figure it out for you.