Microstutters on Vero 4K+

I’m using Kodi 18.9 on a Vero 4K+ and I’m having issues with occasional microstutters during playback (mostly of 4K HDR videos).

My setup is that the Vero connects to my soundset with HDMI, which is in turn connected to my TV (LG OLED C7) also with HDMI, so HD audio like TrueHD is possible to play with passthrough. The Vero is also connected to my local network through gigabit cat6 cables, same goes for my NAS which has all my videofiles.

While playing 4K HDR videos, I get an occasional microstutter where there’s a small skip in the audio and video. It happens randomly mostly every 5-20 seconds or so.

Microstutter happens with:

  • 4K HDR 10bit video with TrueHD audio or with lower bitrate audio (like ac3 5.1 or aac)
  • 4K SDR 10bit video with TrueHD audio or with lower bitrate audio (like ac3 5.1 or aac)
  • 4K SDR 8bit video with TrueHD audio or with lower bitrate audio (like ac3 5.1 or aac)

Playback is perfectly smooth with:

  • all 1080p videos, with or without HD audio and for both 8bit and 10bit video

I have the correct resolutions whitelisted in my settings (like 1080p/23.98hz and 2160p/23.98hz among others) and Adjust Display Refresh Rate set to start/stop and Sync Playback to Display disabled.

I already tried:

  • changing HDMI cables
  • changing cat6 ethernet cables
  • playing from USB drive
  • testing local network speed (it’s about 90-110 MB/s)

The videos that give errors on my Vero play perfectly smooth on my TV’s internal videoplayer as well as on my PC on VLC.

Here are logs of playing a 4K HDR 10bit video with TrueHD audio while frequently microsttuters are occuring: https://paste.osmc.tv/yagahejofi

What can I do to get smooth playback on all videos?

Does this only occur with TrueHD tracks?

There is a known issue with the playback of TrueHD tracks on Kodi (upstream issue).

But the dropouts should be somewhat rare unless you are playing specific titles (Disney studio releases primarily). I wouldn’t expect these dropouts to occur every few seconds however.

You mentioned some sync errors in a previous post, but I’m not sure how you can get that with passthrough, and do see that in the logs you’ve provided here.

Thanks for answering. No it doesn’t. It also occurs with DD+ or DD5.1 audio if the video is 4K HDR.

Sorry but what sync errors? I only had some issues with incorrect calibration and the scanning option on my tv. But that’s fixed now.

The stuttering on 4k hdr files is the only problem that remains. It happens both when I leave whitelist empty and when I select the correct resolutions/refreshrates. And ofcourse sync playback to display is set to start/stop.

You wrote in another thread:

ActiveAE::SyncStream - average error of 14.310407, start adjusting might be the problem

Does the issue occur if you disable TrueHD passthrough so it’s decoded and streamed as LPCM?

Ah yes sorry, that ActiveAe syncstream error was just me trying to decipher the logfile with very limited knowledge. I thought that error had to do with the stutters but it was just a suggestion. But I had no issues with audio sync or whatever. The audio stays sync all the time. It just stutters sometimes.

Thanks for the suggestion. I will try disabling TrueHD passthrough tomorrow. But as I said, the issue also occurs if I set the the audio to a low bitrate ac3 5.1 track.

Thanks – I missed that.
I’d also recommend disabling whitelisting completely as a test

Well, I have no idea how but the problem seems to have fixed itself.

I didn’t have much time yesterday to work on the problem. In the morning I switched HDMI cables to see if that got rid of the issue, but it didn’t. Then friends came over, we watched a 1080p movie with lower bitrate 5.1 ac3 audio without issues (which was ‘normal’ since I never had issues with 1080p). Then I switched back to the original setup with the ‘original’ HDMI cable I had been using (note that both were giving me the same issue). Then we watched another movie; an encoded to a lower bitrate 4K HDR 10bit video with lower bitrate aac 7.1 audio, and to my surprise the microstutter didn’t occur at all and I had perfectly smooth playback.

So then this morning I’ve been testing with the higher bitrate 4K HDR ones with TrueHD audio, and all of them are playing 100% smoothly all of a sudden, while they were giving me major issues previously.

I have no idea how, both HDMI cables were giving me issues, but returning to the ‘original’ one all of a sudden seems to have fixed itself. My settings were untouched. Adjust display to refresh rate is still set to start/stop and the following resolutions and refresh rates are whitelisted:

  • 1080p - 23.98/24/25/29.97/30hz
  • 2160p - 23.98/24/25/29.97/30hz

So, yeah, thanks for the help and let’s just hope the problem stays away :slight_smile: