Migrate library from Vero 4k+ to Vero V

Is there a recommended way of moving my library, watch status, etc from my Vero 4k+ to my new Vero V?


I would say that the easiest way is to use the built-in backup/restore in OSMC and backup everything on a USB-stick.
I think there is more detailed information on how to use it on these forums if you search around.

When done, just fire up the Vero V, pop in your USB-stick and restore from it.
A restart of Kodi might be needed depending on your selection for the backup, but it will prompt you for that.

I’ve just done the same thing myself a couple of days ago for the the first time ever and it went very smooth.


Excellent, I’ll give that a go, thanks

If you are using Trakt for watch status, you will need to validate the new device

1 Like

I’m trying to follow this method to copy my 4K+ settings to my new V, but it’s been a bit frustrating.

On the 4K+ I switched to the OSMC skin, went to My OSMC and really had to hunt around quite a bit to find the backup utility under Settings/Updates (which I would say is not very intuitive). Then the actual backup part is under Manual Controls, whereas Backups just covers the settings for backups, not actually performing a backup. The Wiki is woefully vague on how to do this.

But the bigger problem is that I’m still unable to do a backup. I set Location entry method to “Browsed” and I browsed to my Sandisk USB stick and set the folder to /media/SANDISK/osmc2/.

But when I go to Manual Controls and click on Run Backup of settings now I get an error message saying “Location for backup not provided. Set the backup folder in My OSMC”. (I should add that I’ve had no problem backing up my Embuary skin settings to another folder on the same USB stick, using what seems to be the same backup folder dialogue.)

What do I need to do to backup to the USB stick?

Might be worth trying a different usb port.

I backed up Embuary skin settings to the USB stick successfully just before trying this, so there’s no reason to suspect there’s a problem with the USB port (or the USB stick).

It would seem you ran into a bug. If you go back to My OSMC and make sure your location is still set, then hit OK and then exit out of My OSMC and then exit or reboot from Kodi’s power menu the new location should now be saved and you should be able to perform the backup.

Thanks - got the backup done now. I exited My OSMC and restarted Kodi. Slight worry when I got the frowny face, then the skin came up and I was able to do the back up.

1 Like

I have just moved from a V4+ to V5 and so far impressed no errors no faults just ran out of the box after the restore.
To backup V4 reboot and then backup to SD card not usb. Then pop the backup SD nto the V5 and start.
Enter osmc and do any updates required and reboot.
Then back in and restore backup and reboot.
V5 worked everything restored all Trakt logins worked no reregistering, debrid worked no reregistering.

1 Like