Migration from Raspberry pi 3 (Kodi18) to rpb4 (latest)

Hi there,
I’m trying to migrate from my old pi3 with Kodi18 to a pi4 with the latest OSMC version. I did a backup from the pi3 with the OSMC utility and imported it from the pi4. User preferences seems to be ok but my library is empty. Could it be an incompatibility between the kodi 18 and the new version? Everything seems to be ok when I did the restoring action.

The backup was from Kodi v18? You may be able to get away with this by ssh’ing into your box and…

systemctl stop mediacenter
cd ~/.kodi/userdata/Database
rm MyVideos119.db MyVideos121.db MyMusic82.db
systemctl start mediacenter

The above commands will permanently remove any Kodi v19 or 20 audio and video databases which will allow, if present, a Kodi v18 database sitting in that folder to be upgraded… at least in theory. I’ve never tried it.

1 Like

It worked! Thank you so much.
I just have to find a way to get the cast back on the info page (instead of the banner artwork), some posters seems to be gone too.

That would probably be some add-on that needs to be installed. Maybe extended info or something to that effect. Don’t remember off the top of my head.

That is probably the situation where the the artwork needed to be re-cached but the path stored in the database is no longer valid so it couldn’t download it. You should just be able to highlight one of these entries, info, refresh, and then it should be good again. If you had backed up and restored your Thumbnails folder and texturecache13.db then you might (and I really stress the might part) be able to do a restore again for just those two items… but you might be tempting fate at that point.

Thanks again. I’m using the estuary skin and can’t get the cast part to work. I’ll dive into the code to check where it gets the info.

For the artworks, I tried to choose new ones but didn’t get for some of the entries, even ones that are ok on tvdb. Using osmc for years and I never encountered this kind of issue.

Estuary shouldn’t need anything extra. Check that settings>media>videos>download actor thumbs is enabled. Then in the library highlight a movie with missing actor thumbs and bring up the info screen and then select the “refresh” option. If it asks to ignore local and refresh from the internet select yes. Does this bring the actors in? If so then what scraper is currently set for your sources and are there nfo files located next to your videos.

Download actor thumbs is ON. But it’s weird, the button to refresh data from the info screen is missing.

If your using Estuary it isn’t missing, just off screen. Navigate all the way to the right (or hit direction left when you first bring up the window). If your using the OSMC skin it currently is missing unless you are on staging, or you have installed the update that will be dropping within days of me posting this.

I’m on estuary and I was used to hit this button. It is gone.

I’m not sure how to respond to this. Estuary has a refresh button on both my boxes running test builds as well as my stable release boxes. I literally just double checked both to make sure I wasn’t missing something.

I’m in a loop with:

  • play
  • rating
  • display artwork
  • same director
  • choose artwork

Maybe my skin is broken because of some settings from the imported backup from kodi 18. Can I reinstall it?

No, but you can delete your skin settings via ssh…

systemctl stop mediacenter
rm ~/.kodi/userdata/addon_data/skin.estuary
systemctl start mediacenter

or if the issue is something to do with Kodi’s settings you could reset Kodi’s settings to see if that makes a difference. Note that this one will reset most everything in Kodi’s settings section. Your add-on settings and database will stay intact though.

systemctl stop mediacenter
rm ~/.kodi/userdata/guisettings.xml
systemctl start mediacenter

Well, I understood the issue. My sources where not identified anymore (as movies or TV shows). But if I correct it, my library database is reset. I suspect an issue with the paths. I’ll look at the sqlite to get the differences.

You should be able to set content on your existing sources in videos>files. Nothing should be removed from the Library if you don’t run a clean library. Nothing should be duplicated if your source paths haven’t changed. If you copied over sources.xml from the V18 install this should be the case. Are you trying to remove a source and then set it back up again instead of just doing a set/change content of an existing source?

I was editing the source THEN clicked on YES to clean my library… With the NO option, everything works as expected! The cast part is also fix with this.

Thank you so much for your patience and your perfect advices.

1 Like