Minor Bluetooth/Audio Issues

Hello, I currently have a RPi3 project going making a touch screen car stereo. I’m a novice with all of this so I apologize if it’s easily resolved. I also can’t seem to find similar threads on here. The issues I am currently running into is with Bluetooth. I have carried through what this thread has advised me to do (but back in 2015): [TESTING] Bluetooth audio streaming (A2DP). So, everything is up to date.

First issue:
As I will be taking out my original car stereo, I will need the option to adjust the volume. When connecting my phone via Bluetooth I cannot adjust the volume from the OSMC GUI or from my phone. With both volume adjuster bars from each device, I can adjust the levels but nothing happens?

Second issue:
When playing the music from my phone, it successfully plays through the auxiliary jack to a headset I am using. But, unlike when playing music stored on the OSMC device, the visualizer does not react to the music. Also, the album art and whatnot is absent.

Third issue:
When playing music either via Bluetooth or directly from the OSMC device, I get subtle static in the background and when completely silent. There is also minor tears in the audio. Is there a fix for this?

Device details:
iPhone 6 iOS 9
Raspberry Pi 3 running OSMC 2017.02-2 (kernel: Linux 4.4.27-7-osmc)

Thanks in advance for all of the help!

We plan to implement some volume controls soon, but it won’t work for all devices.

Are you using the internal adapter? Have you tried using an external adapter, such as the OSMC one. This will likely resolve any skips.

Are you using Kodi Krypton with BTPlayer? Make sure the Bluetooth add-on is enabled. Playback information is only possible in the latest version of Kodi when streaming via Bluetooth.

I must say that it is pretty neat to be a part of a forum with quick response, especially from the creator of this project! Thanks for such a quick answer/support!

I was originally utilizing the RPi3’s internal adapter. I do have an external Bluetooth dongle handy - but how do I set it up to override the internal?

When I go into addons it shows that I have BTPlayer enabled. As far as the Bluetooth add-on, am I wrong in assuming that it is enabled if I am able to connect my phone? As far as having Kodi Krypton I am not entirely sure how to find that out either :\

Thanks in advance for your patience. I apologize if what is being asked is simple - I am just very new to all of this.

Cheers!

Easiest way would be to put dtoverlay=sdhost in /boot/config.txt. This will also disable internal WiFi however.

It’s meant to be on by default but this wasn’t always the case.

Sounds like you have it. Check System Information in Settings.

What device are you streaming from? You should get the track info and name when streaming.

Sam

The minor tears in the audio and subtle static still remain after adding this and rebooting the device. I don’t know if it has anything to do with this change I made, but now I don’t see any music playing on the device? I can hear the audio but the interface looks like there is no music playing.

I am using a iPhone 6 to stream the music to the OSMC device. I get track info and name, but the album art and whatnot does not appear (which is fine if that’s not possible). My question was aiming towards the visualizer. The visualizer works with music I have play directly from the storage on the OSMC device, but not when playing audio from iPhone.

You’ve said this one twice now and it’s making me chuckle. What’s ‘whatnot’? Should we be trying to pull genre etc? I’m not sure what else we can get from A2DP unfortunately, but we can have a look.

Hm – some dongles are made better than others. I haven’t experienced this problem myself with an iPhone 6S and OSMC dongle, but I have experienced it with the internal BT adapter on Pi 3 and some other BT adapters.

Sam

Ahahaha, my apologies. Not entirely sure why I put that - habit I guess. The album art and visualizer feedback is primarily what I am looking for. Do you have any idea why the visualizers are not working? I’m using the shadertoy suite.

I’ll give the OSMC dongle a shot and reply on here how it goes.

Because Kodi doesn’t actually really know it’s getting Bluetooth audio.

Streaming is handled by PulseAudio. It’s only thanks to some crafty work from @gezb (who developed BTPlayer and our add-on) that we can inform Kodi we’re playing some audio. We primarily do this now to avoid sink lock: where you’d get problems if both Kodi and PulseAudio tried to play sound at the same time; but there’s an added bonus of being able to provide visual confirmation that we’re playing something and some information. The information we can show is a little limited at the moment.

Give that a shot: it’s no silver bullet, but things certainly won’t get any worse. And all improvements we make are tested using this dongle. Make sure you reboot and repair with the OSMC dongle when you get it.

The static might be digital hiss from the powersupply or pi circuits. You can try to isolate the audio line with a noisekiller when in the car.

Those are audiotransformers that isolate the signal from a common ground and normally used in car audio installations to prevent noise from the engine and other devices going to the stereo.

Sorry for the delay… busy work week. Do you have any suggestions that would work? I’m assuming a Yeeco TDA 7850 is not the same thing? I’m utilizing this from a project page I saw for a RPi car stereo

I guess something like this might work:
http://m.ebay.com/itm/NEW-PAC-SNI-1-CAR-STEREO-RCA-NOISE-ELIMINATION-FILTER-GROUND-LOOP-ISOLATOR-SNI1-/152267295838?nav=SEARCH

Edit: If you did not test your setup in the car, I’d suggest to do that first. It might just be a noisy wallplug.