Missing Audio Passthrough Config - Post Vero V migration


I’ve just migrated from a Vero 4K+ to a Vero V and I’ve noticed that audio is only PCM. I went into Settings > System > Audio to enable passthrough, but I can’t see the passthrough options. I’ve tried a different HDMI input on the Amp, and a different HDMI lead.

Connectivity is: Vero V > Onkyo Amp > Samsung UHD TV

This was working before on the Vero 4K+

I suspect I’m doing something really silly, so apologies in advance if it is!


Thanks for your help.

change the view from advanced to expert.

Thanks for the quick reply @darwindesign, no luck unfortunately

Switch your skin to Estuary temporarily and see if it shows up there. Is this a manual clean setup or did you import your settings from a backup. I’m scratching my head a bit on this one as I can’t think of a reason why that setting isn’t showing up.

Thanks, I’ve managed to fix it. Estuary had the same issue, however I tried the “Reset above settings to default” and the options returned (and are still visible now I’ve returned to the original skin).

I did a full settings restore from the Vero 4K+ (except thumbnails) on the Vero V.

I see the passthrough options include the passthrough device… I wonder if the old Vero 4K+ output device is in the configuration file that is imported, but because the hardware doesn’t exist that section errors out?

I checked my other Vero - which has just gone from Vero 4K to V (same migration process). That looks ok, although it doesn’t use Passthrough, so maybe that section of the config isn’t stored/imported.

Anyway, thanks for your help, much appreciated!

I don’t think that device selection should make a difference here. There might be a clue if you ran a diff between the guisettings.xml from the Vero 4K and the one currently working on the Vero V if your really curious. Nice find on the solution. :+1:

Thanks for your quick support @darwindesign

In case it’s of any use/interest to others, I found the following diff’s between the original 4K+ backup and the (now fixed) Vero V guisettings.xml


<setting id="audiooutput.audiodevice">ALSA:default</setting>
<setting id="audiooutput.config" default="true">3</setting>
<setting id="audiooutput.passthroughdevice">ALSA:hdmi:CARD=AMLAUGESOUND,DEV=0</setting>


<setting id="audiooutput.audiodevice">ALSA:hdmi:CARD=AMLMESONAUDIO,DEV=0</setting>
<setting id="audiooutput.config">1</setting>
<setting id="audiooutput.passthroughdevice">ALSA:hdmi:CARD=AMLMESONAUDIO,DEV=0</setting>