Missing library titles

I switched to using fstab for 2 nfs shared folders on a Synology nas. After cleaning and updating my library I want from 424 titles to 336 titles. Tried cleaning and updating again to no avail. Also confirmed in the files section I can see all of the titles. One folder shows 300 entries and the other 124.

It looks like an issue with the movie scraper which is set to TMDB Python.

You could have saved yourself a lot of trouble by just path substituting from your existing sources to the system mount but it is a bit late for that now. Your going to need to provide logs and some more detail for anyone to be able to figure out what is going on. What is different between what is scraping and what is not? Does one have nfo files? In this process did you change scrapers (ie you were using TVDB before and used this switch to move to TMDB)?

Noticed this since updating. Full movies are not showing and use simple NFS paths rather than NFS mounts.

Also using Synology NAS with titles such as The.Doors.1991.Theatrical.Cut.GBR.UHD.Bluray.Remux.2160p.HEVC.HDR.Atmos.7.1 not showing in movies library despite others in same folder showing fine. Also missing simplified film names for example only showing 2 of 3 Matrix movies in Matrix set.

@Eternal_Pessimist Hi, can you open a separate thread, please? Thx. If it figures out to be the same issue like @BlueGTR has, we can merge the both topics, again.

@BlueGTR: To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


I checked a couple of the missing titles and didn’t notice anything different about them. My collection is a mostly mkv with some ISO.

Below are 2 examples of filenames that are missing in the Movie view but show up in the file view under videos. I didn’t create any nfo files and am using the same default scraper as before TMDB Python.

The Predator (2018).mkv

There is a setting at settings>media>video>use video tags> that you should disable and see if a library update will then pick up most if not all of the missing files. I can’t quite see if this is exactly where the issue is as it didn’t look like those logs had a library update contained within them.

I also noticed that even though you created the system mount you didn’t actually change your sources in Kodi to use them nor did you add a path substitution to be able to use them without having to rescrape your library.

Just an FYI if you look at TMDB’s web site you will find three different movies with the title of “Cliffhanger”. Unless this file is sitting in a folder titled with the year, or a nfo being created, how is Kodi suppose to figure out which of the three it is?

I also noticed after the last post that you may have your TV and movies mixed up in the same source. Kodi is not going to scrape correctly if this is what you have done. Please see this other thread where I recently covered this topic. If you have any further question about this you can ask here and not in the other thread.

Disabling video tags picked up most of the missing titles and got me back to where I was before. There may be a small number of titles still missing but that’s not new. Mostly all of my content is Movies. There are a few documentaries and concert videos in the same folders. I guess those are considered TV? I’ll read through the other thread on the scraper issues and see if I can figure it out.

After adding the system mount point in fstab I deleted the old video sources that were under Network File System (NFS) and added the new ones under nfs://. Was there another step I missed?

Thanks for the help!

If there is a title you can’t figure out how to scrape feel free to post the file path and I can try to help you spot the problem.

It depends on what the scraper has it set as. Your using TMDB so the best way to solve where to put it is to just search the title name at TMDB’s web site. If you look at the url for any given listing it will show /tv/ or /movie/. The main thing here is that to never nest a source folder of one type inside of another.

Your current file paths (nfs://*) your using as your sources is Kodi directly accessing the network resource. The mount points you setup are in /mnt/. To use these system mounts you have two choices. The first choice is to read through the howto I linked in my first response and use that information to make a path substitution. Basically you would leave your library and sources exactly as they are now and just add some instructions to Kodi that says instead of using this file path go to this other place instead. Your other choice is to delete your sources and your current library and start over again (again) but this time making your Kodi paths go to /mnt/... instead of nfs://...

Thanks for explaining the mount points. I’m just going to delete my library and start over again. Not sure my fstab mount point is working. Is it supposed to be listed when browsing add video source?

You would choose Root Filesystem and then mnt and it should show there

1 Like

I got it to use /mnt and after renaming a few titles everything now shows up in my library except for one that isn’t listed on TMDB.

IMAX Dream Big Engineering Our World

Yes it is. It should scrape automaticly if you have your file named something like “Dream Big Engineering Our World (2017).mkv”. Alternatively you can make a text file with the exact same name as your video except with a “nfo” extension and inside of the file you would put the url to this title on TMDB…


Thanks, removing IMAX from the file name fixed it.

1 Like