MMAL Skipped frame or judder every few seconds

Having watched a few episodes with OpenELEC and the lirc_rpi module enabled definitely introduced stuttering through the whole episode. Not 100% sure yet if disabling the module in OSMC removes the stutter 100% though. I have to test some more. Lets see what Sam comes up with. Would still be better if a few others could test this out. Where’s @Jdiesel?!

@kartana if you want to wake up people put an @ in front of their name @Jdiesel

1 Like

Ah, thanks @fzinken! Wake up @Jdiesel, we miss you! :smile_cat:

I turned off lirc_rpi and watched a 30min clip today and I didn’t notice any stuttering, not 100% sure either but it looks promising.

Sorry I’m away from home and won’t be able to test until later today.

I can confirm that disabling the lirc_rpi module not only significantly improved the studder issue I was having with MMAL playback but also improved remote control responsiveness with my RC6 IR reciever.

this also worked for me!!

1 Like

Good find.

cat /proc/interupts doesn’t show me any IRQs when I haven’t got a GPIO receiver attached to the board ,but popcornmix suggests the driver may still be doing something on the transmit side.

I’ll disable this by default in future updates.

Sam

Thanks @kartana

I still notice the odd shudder every so often but rather then every 5 seconds it is now every 5 minutes. I can definitely live with that.

Yeah @Jdiesel there seems to be slight stutter every few minutes for me too. No clue why. Might be the video file but I have no idea how to check the time stamps (that might cause stutter if they aren’t correct). But it seems to happen on most if not all my files so I think that’s not it. Removing the lirc_rpi module did improve things significantly though.

Can we not mark this as resolved. The big issue was the module but I mean I have this slight stutter every few minutes while using MMAL since using a RPi2. Regardless of adjust refresh and sync options, LAN or USB. It’s always there. There is nothing on CodecInfo that would suggest any frame drops etc. I’ve read a lot of threads on this issue and @popcornmix most of the time suggests using OMXPayer instead of MMAL but is this really a solution? I find the quality from OMXPlayer worse. The stutter is gone when I switch to it though. What is causing this?

Edit: have you tried using OMXPlayer @Jdiesel?

Ok,

I’m having similar issue but noticeable only on live TV streams.

I have to disable MMAL acceleration in order to get smooth playback. When MMAL is enabled it stutters every 2-3 seconds.

Tried playing various movies from NFS and they are fine with MMAL enabled.

Any ideas?

The stutter returned yesterday without changing anything. At first I thought it was the file but I put the SD card with OE in and it played fine. Both use the same addons (just a skin) and settings. I have no clue why OSMC doesn’t run properly on my RPi2. I’m out of ideas.

Are you running an OE Jarvis build, or an Isengard one…? It’s possible there have been some changes which are impacting performance.

OE build is Isengard.
I’ll test OSMC Isengard as well as a OE Jarvis beta build in the next days and report back. This is driving me nuts, but other people don’t seem to have the problem (after finding the lirc_rpi problem) so not sure what to think…

Hello,

i’m new here. After thinking getting crazy i stumbled upon this thread. I’m running a clean install of osmc with latest updates on my raspberry pi 3. All movies and the .kodi folder are mapped via nfs. With this setup i also get this stuttering without finding a combination of settings to avoid it. I’m out of ideas. This happens with 23…fps, 25 fps and 50 fps videos on 23… Hz, 25 Hz, 50 Hz and 60Hz TV. And also only with mmal enabled. None of the audio and video settings (and combination of them) beside of enabling omxplayer seems to have any effect.
I’ll keep on reading this thread. If i can provide any infos to help to solve the problem, please ask.

Thank you,
Tom

ps. i already disabled the lirc module in config.txt
ps2. stutters appear aprox. every 20 seconds
ps3. i was very brave and tested the dev. version from the @gmc repo (rbp2-mediacenter-osmc 16.8-043). exactly the same.
ps4. removed all “my osmc” related stuff, no change.

@tomnat
I assume you are running with “adjust display refresh rate to match video” and “sync playback to display” (they are both recommended).

Any peripherals (e.g. USB) attached?
Do you get this with a clean install, with no add-ons or custom settings? (Add the two settings mentioned above and disable lirc module)

Do you have the issue with openelec? That may narrow it down to being a kodi issue or a kernel/distribution issue.

Thank you. It happens also with the settings mentioned. There is only a osmc remote connected via usb. There are no additional addons installed.

I havent tried openelec yet. I’ll give it a try.

Thank you,
Tom

For completeness could you unplug then when playing? (or use a standard USB keyboard instead).

Genius! Its the remote!!! I have now testet multiple times with and without the rf usb dongle. Every time the usb dongle was connected, the stutter was present.

I’m now happy to know the reason and sad, thats the remote.

Thank you!
Tom