MMAL Skipped frame or judder every few seconds

Just to confirm, this was with the USB dongle as well?

OpenElec 6 runs the Isengard (15.2) version of Kodi, OSMC is running Jarvis 16.0.

This makes any such comparison an Apples and Oranges comparison. More likely you are comparing different versions of Kodi than you are comparing different operating systems if one is not giving you this issue.

I tried OpenELEC with the dongle and i saw no stutter. Tests without dongle on OpenELEC seemed useless. Back to OSMC the stutter was present immediatelly and gone everytime i disconnected the usb-dongle. So it seems, that neither Kodi, nor a general Linux kernel condition causes the stutter. I thought about some interrupt-problems (flood), but was not able to analyze this further. Could it be some kind of the problem described here: Raspberry Pi 3 UART speed workaround « Adafruit Industries – Makers, hackers, artists, designers and engineers! ? I don’t really know the implementation of the usb_hid…

Thank you,
Tom

In MY case it doesn’t matter which version I use. OSMC has the same behavior across the last two Kodi releases! Can’t speak for others so since we are probably starting to mix the issues here.

Am I able to log the “top” output somehow?

Uh, ok, sorry. Didn’t mention this.

You might want to try bcmstat.
A very useful tool for monitoring cpu, memory, interrupts, temperature, clock speed etc.

1 Like

I just finished testing with OpenElec 6.95.1 and do not notice the stuttering. I only had a chance to test a few videos therefore it is too early to tell if the issue is completely nonexistent on the OE Jarvis beta build.

This is the cause of the lirc based stutters:

Once the fix is accepted in master we’ll pick it up for Jarvis/OSMC.

1 Like

Thank you for pointing this out and for you efforts to solve this problem!

Deleting the dtoverlay line worked for me too. I was naggin this stuttering some time ago and i was blamed a troll, then i changed to omxplayer and the problem disappeared. But now i bought a projector and I was having a hdmi signal problem with omxplayer, so changed to mmal becuase hdmi doesnt loose signal with that. But then i had the stutter problem again.

Long story short, editing config.txt worked for me!

Many thanks to the guy who found the problem.

almost forgot. I’m using rpi 2

I can confirm tomnats findings. I had a lot of frame skips. I disabled lirc_rpi and I got way less frame skips but still some. Then I pulled my OSMC remote dongle and I got 0 frame skips.

I hope there will come a fix so I can use the remote again:-).

I’m using a rpi3 and a USB sound card so I have to use MMAL.

There will be a fix for this in a near future update

Sam

I still have skips with OSMC though. I tried everything and have to give up on OSMC for now. OpenELEC runs without problems, no skips. I have no idea what it could be. In the end I just want a working version of Kodi and for me, OpenELEC (LibreELEC too) is just working as expected. I would still prefer a non skipping OSMC though.

Hi

@popcornmix already found the cause of the problem. It will affect both OSMC and OpenELEC platforms, although OSMC may be affected with a greater severity. This fix will be released in OSMC within a few days.He also found another vchiq bug which will resolved a lot of stuttering issues as well.

I would appreciate it if you could try after the next update and let us know if the situation is improved

Sam

2 Likes

Yes, naturally :slight_smile:

Hello Sam

do you think popcornmix’s fix will be backported to Kodi 16 ?
It seems to be for Krypton…

This was covered a few posts above:

1 Like

For sure i will test immediately after an update.

I wanted everybody to know, the stutter ist gone with the april-update.

Thank you for you excellent support and fix!
Tom

1 Like

8 posts were split to a new topic: XVID files judder