XVID files judder

I am getting the same skipping every 5 seconds or so with XVID 23.975 FPS files on my Vero 2. I have done every variation of settings and am unable to stop this from happening. Vero 2 with HDMI to TV, SPDIF Digital to Receiver.
Would the same issue above be causing this on the Vero 2?

The fix in this thread applied to a bug where you had a skipped frame exactly every 10 seconds (the polling interval for checking for new input devices).

If you are seeing skips every 5 seconds, then it is a different bug.

Thanks I will confirm the exact time between skips just to be sure. Cheers

I am super pleased to say thankfully it is every ten seconds exactly! How do I apply this fix to the Vero 2? I can’t tell you how much this has been bugging me… cheers

@sam_nazarko are you able to help with my issue on the Vero 2 please?
see above comments.

Hi Wayne

Check that your device is up to date. The latest version of OSMC has a fix for this issue, but it may not necessarily be causing the problem.

If the issues persists I’d recommend a new thread and a log so we can see what is happening

Hi Sam,

My device is up to date. Here is a sampel media info link - the same problem occurs on all xvid 23.975 format files. Everything else plays perfectly… http://paste.osmc.io/ogehaveluh.tex

Here is my log link: http://paste.osmc.io/acinefamuj

let me know if you require anything else?

Appreciate you looking into this thank you.

kind regards,

Wayne

I’m going to split this in to a separate thread.

Hi Wayne

Please try the following build. You can run these commands via SSH. I’d be interested in knowing if this helps with the problem.

wget http://apt.osmc.tv/pool/main/v/vero2-mediacenter-osmc/vero2-mediacenter-osmc_16.1.0-5_armhf.deb -O mediacenter.deb
sudo dpkg -i mediacenter.deb
rm mediacenter.deb
sudo reboot

Sam

Hi @sam_nazarko I tried this the other day and it affected .mkv files that were playing perfectly in the past so I had to reinstall OSMC from scratch. The effect was slow motion type effect on those files. Also the issue in question was still apparent - every 10 seconds there was a slight pause/jump in video on the same file I showed you in the log. I don’t know why but there seems to be numerous issues playing different types of media which have never been a problem in the past (prior to Vero 2). Everything played fine on my old Apple TV with OSMC. I really hope you can fix the issues for the community. cheers Wayne

Hi Wayne

We’ll get it sorted out.

Are you saying that it used to work OK with a previous version of OSMC on Vero 2?

Check PM. A sample will help.

Sam

I have the same issue, 10 seconds apart.

I assume you are on the latest version with the Xvid fixes included?

I’m on the latest version, yes. Do I need to do anything in particular for Xvid fixes?
I just ran update, upgrade, autp-remove and confirmed after a reboot. It’s still skipping every 10 secs. Although the first skip was 13 secs into the file.

These issues seem largely solved, so if it persists for you it would be good to know when it started happening and see a log.

I’ve only had my unit for about a month or so. I don’t recall ever seeing it play these files without skipping. My other devices play the files without issue.
At first I thought it might have been my settings causing the skips, but I’m seeing the same 10 second interval as Wayne.

The implication of input polling led me to try unplugging USB stuff. The skipping stopped after unplugging the Vero remote receiver. The skipping resumed after plugging it back in.
The rear and side ports have the same effect.

Don’t use upgrade, it will break things. Always use dist-upgrade.

https://osmc.tv/wiki/general/keeping-your-osmc-system-up-to-date/

That’s helpful, thanks.

We did resolve this issue on Vero 2 as well about a week or so ago. As @actiona says, an ‘upgrade’ is not a full upgrade, and you should always use dist-upgrade. Your system may not be upgradable in the state it is in now, but it’s worth a shot.

Alternatively, install the latest May version from osmc.tv/download, and do an update via My OSMC after the first boot. With any luck, your skips will be gone.

Cheers

Sam