Mode not supported error message on TV

I’m a newb and am having a good time tinkering with OSMC. My problem is that I’m getting an error message on two different displays that I plug into. Both say a variant of “Mode not supported”. The message comes from the display and/or TV, it is not an OSMC message. At one point, I searched and found a thread on this forum that mentioned this:

“Followed the suggestion, and redid sudo apt-get update && sudo apt-get dist-upgrade && sudo reboot. Picture came back. Thanks!”

That caused something to update with the dist-upgrade part and then everything worked for a reboot or two. I can get SSH access, but I’m at a loss as to what to try next. I have also tried a new HDMI cable, but that didn’t help.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

1 Like

Ok, here goes.

The problem: I recently bought a Raspberry Pi 3 Model B. I used the Noobs tool to load up the OS for OSMC. It worked fine then. As part of the setup tool, I updated OSMC and that is when the issue first appeared. It may not be related to those steps, but I keep getting “mode not supported” from any display I plug into the HDMI. I have tried new power supplies and different HDMI cables.

What I was doing: After a reboot, the issue occured. Once, I was able to run the commands mentioned in my post above, but it only solved the problem temporarily. I’m not back to “mode not supported”

Can I replicate the issue: Yup. I’m stuck and cannot get a display. I can SSH in though.

Device: Raspberry Pi 3 Model B

Peripherals: A USB wireless keyboard and the HDMI monitor/tv. Both HDMI devices have the same ‘mode not supported’ message.

Past experiences: I’ve only just begun with OSMC and this issue has popped up twice. I cannot figure out what causes the problem to go away. I can say that once when I booted, I did not get the ‘mode not supported’ but got a display washed out in green tones. It was nearly unusable. When I tried to change display resolutions, I got the ‘mode not supported’ message.

Logs:
I have generated these log files via SSH, as I cannot get a reliable display. In this example, I am seeing a green mess of flickering over my Samsung TV:

https://paste.osmc.tv/epexucomed

Your display EDID is not being read. It seems the Pi is trying to send 1080p 60Hz - surprising your TV doesn’t support that if it’s fairly new (at least ‘HD ready’). You could try putting:

hdmi_group=1
hdmi_mode=20

in /boot/config.txt. See Video options in config.txt - Raspberry Pi Documentation for other options.

1 Like

If you only plan to run OSMC then please reinstall with OSMC Pi2/3, since
these settings make no sense on a Pi3

NOOBS Auto-generated Settings:

arm_freq=850
core_freq=375

So, install from Download - OSMC - if it still doesn’t work then RMA the Pi3 since you have tested on two separate TVs.

Regards
/L

1 Like

I ended up RMA’ing the Pi. The new one has no problems. Thanks for the help everyone.