Model B instant crash

On my model B I am getting this error after install on boot:

of_platform_populate failed: -22

immediately on boot, the system goes to the OSMC load screen at 0% before recycling through the same.

I have tried a different SD card, redownloading the Alpha 4 image & reextracting as well as more than one install to both SD’s i tried.

Could you grab /boot/install.log and post it to and provide the link.


apologies, but is this from the SD card or the machine the card written from?

If its the machine, what would the windows path be?

/boot/install.log is on the card.

Sorry, either my install is totally boned or I’m missing something, I got on my SD card and went into the filesystem.tar and to boot but there is no /boot/install.log file.
Also I tried to mount /sdd2 on my Ubuntu server and it didnt like that.

Is there a install.log on the root of the card?

No there is not;
bootcode cmdline config filesystem.tar fixup.dat preseed.cfg start.elf zImage

in /boot there is
dtb * (folder) overlays (folder) bcm2708-rpi-b.dtb bcm2708-rpi-b-plus.dtb bootcode.bin config-3.18.5-2-osmc fixup_x.dat kernel.img LICENCE.broadcom start_x.elf vmlinuz-3.18.5-2-osmc

building a xubuntu usb now will try install from linux.

The windows osmc installer should work fine.
You are deffo selecting:-
Raspberry Pi
Alpha 4
SD Card


Correct those are the options i used

Do you have another power supply that you could use?

1 Like

heeeyyy actually seeing some movement. power supply is from my smart phone rated for 850 mA - it must have been the cable /facepalm

Thanks much for your help!

1 Like

Happy to help.