Model B+ Wont Boot

First time trying out OSMC, used Kodi for the last few years. I have tried booting to OSMC with two different Model 2s, and two different SD cards. The only result I get is Rainbow Screen of Death, where all I see are colours, and all lights on the Pi go red.

I tried using the Windows installer, for the raspberry Pi 2, I even tried an older image, I redownloaded them both, all four times, it failed. I downloaded an image, unzipped it, and copied it to the SD card, and nothing happened.

I have no idea what steps to take next

Rainbow Screen very often indicates that the wrong image has been chosen.
Have you chosen the RPi2 image and are you 100% sure that you really have a RPi2? Especially as in the titel you wrote B+ which is a RPi1.
Maybe post a picture of the PCB so we can tell

These are the raspberry pi’s

Your Raspberries are 1 not 2 and you foot look tiny compared to the RPi’s :slightly_smiling:

Use the RPI1 Image and you will be up and running in a minute

But I thought only the 2 came with 4 USB ports?

Nope, you have a Raspberry 1 B+

You’re right, I just started updating my scrapers on OSMC, using the Pi 1 image!