Mopidy on Osmc Alpha 4

Hi,
Can I instal mopidy on osmc?

Looking for the same thing. Not sure if its best to start with a modipy/pi musicbox install and add kodi/osmc or start with osmc and add modipy.

I would be very interested in this too…

Don’t think it would be a problem if you follow: https://docs.mopidy.com/en/latest/installation/debian/#debian-install
The only thing that could interfere would be alsa, but I think @sam_nazarko can tell more about that :smile:

After I’ve installed Mopidy, OSMC stopped working.
OSMC doesn’t work with newer libtag.so.1.
Mopidy docs suggest to create a symlink (replacing system-wide libtag with xbmc one), but I can’t find any libs in .kodi/system directory.

Link do mopidy docs:
https://docs.mopidy.com/en/latest/installation/raspberrypi/#appendix-b-raspbmc-not-booting

Hi again,

After some struggling (alsasink this, modprobe snd_bcm2835 that…), I’ve managed to install mopidy on OSMC, and have it working. The problem is, after some time (mostly after playing music for a while), something breaks in Kodi, and I can’t launch any video (Kodi just hangs on a black screen). I can press “stop”, and it brings me back to the GUI, but the only way to have Kodi play anything again is by restarting the Pi… Not really WAF.

I’ll try to grab a log next time it happens, but do you have any idea about what’s happening ?

Could you write a summary of how to get mopidy working? That would be sweet!

I think I’ve made some progress on this. Basically it seems that when Mopidy is either using the sound driver, or has it on standby, OSMC is struggling to claim access to it (I have little understanding of how hardware drivers actually work).

I have discovered that if I pause Mopidy, and try play a video on OSMC, I experience the black screen. However, if I STOP Mopidy before playing a video, then things work perfectly.

I am running:
OSMC RC2
Raspberry PI B+
Mopidy 1.0.4
Output via passthru to amp
Tested on DTS audio to ensure passthru wasn’t affected

To install Mopidy I followed these instructions: http://geeks.noeit.com/turn-your-raspberry-pi-into-a-spotify-server/. You can ignore the part about libtag, this doesn’t seem to be an issue on this version of Kodi.

I then installed MPC (and Spotmop - https://github.com/jaedb/spotmop/) as Mopidy clients. This allows mpc pause and mpc stop commands for Mopidy server.

Would it be possible to have OSMC use the HDMI and Mopidy use the analogue audio output? Maybe they will not interfere. And analogue output would be good enough for Spotify (for me). Otherwise a external DAC might be an option.

I followed those instructions and now I’m stuck in a boot loop :frowning:

If someone could make OSMC and mopidy play along or even share now playing (i.e. when playing something in mopidy it would show up in OSMC, and when starting something in OSMC that would automatically stop mopidy) that would be great.

I solved the issue by removing the conflicting packages by issuing

sudo dpkg --purge libtag1-vanilla:armhf libtag1c2a:armhf gstreamer0.10-plugins-good:armhf
sudo dpkg -r --force-depends libtag1-vanilla:armhf libtag1c2a:armhf gstreamer0.10-plugins-good:armhf

(yes I did both even though they should be doing sort of the same thing)

After running

sudo apt-get -f install

Everything worked fine! (until I received a kernel panic and my SD-card broke. Probably unrelated)

I am wondering if the sdcard happened again with somebody or if its just you. I also had sdcard problems.
Or did you fix everything

I have a fully-operational OSMC 4.4 and Mopidy 2.0 RaspberryPI 2 by following these steps:

  1. Install mopidy apt-get install Mopidy
  2. Add mopidy repo GPG key wget -q -O - https://apt.mopidy.com/mopidy.gpg | sudo apt-key add -
  3. Add repo sudo wget -q -O /etc/apt/sources.list.d/mopidy.list https://apt.mopidy.com/jessie.list
  4. Update apt-get update and install apt-get install Mopidy-Spotify
  5. Install cffi apt-get install python-cffi
  6. Install gstreamer-alsa apt-get install gstreamer1.0-alsa gstreamer1.0-tools
  7. Install Spotify pip install Mopidy-Spotify
  8. Run mopidy mopidy to create your default configuration file, and then close. Edit the config (ie ~/.config/mopidy/mopidy.conf) and set [audio] output = alsasink
  9. [optional] install Spotmop web interface pip install Mopidy-Spotmop

Please note that as mentioned, to avoid audio device conflicts, you need to STOP mopidy’s currently playing track prior to playing any media with Kodi. Ie mpc stop.

1 Like

How do you know taht the output audio is alsasink and so gstreamer1.0-alsa is needed ?

This is ok for me :slight_smile: but when i put mopidy at server it does not work anymore.
I put the configuration file in the correct directory (etc/…)

The log seems ok… but ?

I know this as a result of trial and error :slight_smile:

Please provide more information about the issue. What exactly is not working?

I recommend editing the user-specific configuration file rather than the system-wide one. See ~/.config/mopidy/mopidy.conf but be aware of the user has started the Mopidy server.

Hello,

I followed jaedb’s steps and mopidy works now. However, it is playing from the onboard soundcard, whereas I have and external usb soundcard. This soundcard works when I play an audio file from Kodi, but Mopidy is not playing through it.

Does anybody have any idea which settings to change to make mopidy play through my usb soundcard as well?

Cheers,

Daan

I got mopidy playing through the usb card by following these instructions and restarting ALSA with sudo /etc/init.d/alsa-utils restart. I set Kodi to play sound through HDMI and the onboard soundcard and now Kodi and Mopidy can play simultaneously without problems.