More Update Failures


#1

Hi,
I haven’t been able to get an update to work since January. every time the update fails I end up having to manually re-install version 2018.01-1 because it’s the last one that actually works.

Here’s the details: Raspbery Pi 1 v2 with a hard wired internet connection not wi-fi and a USB install to a hard drive…
On bootup with version 2018.01-1 everything proceeds as normal. But after any update the bootup fails.
Tonight I let it update to the latest version and it now fails to find the hard drive and halts the bootup. On screen reads as follows:

waiting for root filesystem device /dev/sda1 (that’s as it should be so far) then we get:
Fatal Error: could not find root file system /dev/sda1 - if this is a USB install please check the USB drive is connected.
OSMC initramfs Rescue Console.
for help and support see https://osmc.tv/
/#_

And that’s where it stops every time…
I’m not even able to ssh into it, because obviously it hasn’t even booted. It’s not a faulty card, or a faulty hard drive or anything hardware here that has a problem. As I said if I re-install 2018.01-1 as a USB install from scratch, it all works fine. But it won’t work with anything beyond that. It’s something to do with the software configuration beyond version 2018.01-1

It’s not the first time I’ve reported this, but I still don’t have a solution or a reason it’s happening

Is there a known fault and solution please?


#2

We’re not aware of update issues.
The number of USB installations is small, but still noticeable.

When you say new versions cause issues, have you tried downloading 2018.02 or 2018.03 to rule out an issue specifically with 2018.04.

From your post history, I’d suspect a hardware issue.

Which PSU do you have?
Which SD card do you have? Is it old? Where did you get it from?

If the issue only occurs post-reboot of update, you could try updating via command line and sending us the output of grab-logs -A just before so we can see how the update has been tolerated before you reboot and the update fails.

Sam


#3

Do you have more than 1 USB drive connected? It could be that they are being recognized by the Pi in a different order sometimes. Try with just the main boot drive connected.


#4

Thank you for your reply Sam, In answer to your questions:
I have not tried directly installing 02 03 or 04 the boot failures have occurred on update from V2018-01. I’ll try that next and see if 04 will run from a fresh install as that would confirm or rule out a problem with the update process itself. And may help you to track it down.

The PSU on the Pi is a custom built one that I built to fit inside the media box it lives in. It can provide a stable regulated current in excess of 4.5A under load. So it’s not the supply… The Hard Drive has its own separate PSU and doesn’t draw current from the Pi.

The memory card is a 16Gb Sandisk Ultra class 10 card. Purchased locally, so I know it’s the real thing and not a fake. But it isn’t a fault with that because, I’ve tried this with several different cards just to rule out a card problem. The result is the same each time.

Updating via the command line is possible I suppose, I’d have to dig into the exact command sequence to type, to get you any useful information because I haven’t done it that way before. Only via My OSMC in the program menu. and I’m not very good with Linux :frowning:

I’ll see how it goes installing 04 from scratch first… that will confirm if it’s an update only issue. I’ll report back later.

I’m also wondering if it’s an issue related to the Pi1 … I’ll also try out an install and update on a Pi2 instead to see if that works… I’m guessing that there won’t be many people using a Pi1 in their media box any more LOL :grin:

@bmillham Thanks for the suggestion, but there is only one hard drive connected.

Thanks Guys!


#5

sudo apt-get update
sudo apt-get dist-upgrade


#6

Thank you… yes… but I’d also need to know how and where to do the log grab in that sequence so that sam can examine it.


#7

Well after sudo apt-get dist-upgrade you can rung grab-logs -A and provide the URL.
When using commandline dist-upgrade the device will not automatically reboot so you can upload the logs before you reboot.


#8

Thank you!! I’ll take a look at that later today.


#9

OK I just pulled the SD card and this is a copy of the install log… I can’t see any problems. Before the reboot it can clearly see sda1 and write to it, after the reboot it fails to be able to see the drive as being attached.

Thu Jan 1 00:00:11 1970 Starting OSMC installer Thu Jan 1 00:00:24 1970 Detecting device we are running on Thu Jan 1 00:00:24 1970 Mounting boot filesystem Thu Jan 1 00:00:24 1970 Trying to mount to MNT_BOOT (/mnt/boot) Thu Jan 1 00:00:24 1970 Using device->boot: /dev/mmcblk0p1 and FS: fat32 Thu Jan 1 00:00:24 1970 Preseed file found, will attempt to parse Thu Jan 1 00:00:24 1970 Found a definition for storage: usb Thu Jan 1 00:01:37 1970 Creating root partition Thu Jan 1 00:01:38 1970 From a root partition of /dev/sda1, I have deduced a base device of /dev/sda Thu Jan 1 00:01:38 1970 Must mklabel as root fs is on another device Thu Jan 1 00:01:38 1970 Going to mklabel with device: /dev/sda with a label type of MSDOS Thu Jan 1 00:01:39 1970 Calling mkpart for device: /dev/sda and fs: ext4 with start 4096s and end 100% Thu Jan 1 00:01:41 1970 Calling fmtpart for partition /dev/sda1 and fstype ext4 Thu Jan 1 00:01:48 1970 Filesystem label= OS type: Linux Block size=4096 (log=2) Fragment size=4096 (log=2) Stride=2 blocks, Stripe width=1024 blocks 9773056 inodes, 39072000 blocks 1953600 blocks (5.00%) reserved for the super user First data block=0 Maximum filesystem blocks=0 1193 block groups 32768 blocks per group, 32768 fragments per group 8192 inodes per group Superblock backups stored on blocks: 32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208, 4096000, 7962624, 11239424, 20480000, 23887872

Allocating group tables: 0/1193 581/1193 done
Writing inode tables: 0/1193 done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: 0/1193 344/1193 done

Thu Jan 1 00:01:48 1970 Mounting root
Thu Jan 1 00:01:48 1970 Trying to mount to MNT_ROOT (/mnt/root)
Thu Jan 1 00:01:48 1970 Using device->root: /dev/sda1
Thu Jan 1 00:01:49 1970 Extracting files to root filesystem
Thu Jan 1 00:01:49 1970 Starting extract progress…
Thu Jan 1 00:05:50 1970 Extraction of root filesystem completed
Thu Jan 1 00:05:50 1970 Configuring bootloader
Thu Jan 1 00:05:50 1970 Configuring bootloader: moving /boot to appropriate boot partition
Thu Jan 1 00:05:56 1970 Configuring boot cmdline
Thu Jan 1 00:05:56 1970 The revision for this device is
Thu Jan 1 00:05:56 1970 Configuring /etc/fstab
Thu Jan 1 00:05:56 1970 Successful installation. Dumping log and rebooting system

The cmdline.txt is: root=/dev/sda1 rootfstype=ext4 rootwait quiet osmcdev=rbp1

again no problem there…

Not sure where to go with this one… it’s obviously not mounting sda1 otherwise it would be able to see it.


#10

OK Further to the above… I’ve now eliminated it being a Pi1 issue… I tried a from scratch USB install of 02 03 and 04 on the Pi 1… same result 02 and 03 leave me with a blank screen and just an underline cursor and 04 results in the message:
waiting for root filesystem device /dev/sda1
Fatal Error: could not find root file system /dev/sda1 - if this is a USB install please check the USB drive is connected.
OSMC initramfs Rescue Console.
for help and support see https://osmc.tv/
/#_

So to eliminate it being an issue with the pi1 I did exactly as above, but with a Pi2 (and obviously selecting Pi2 in the installer) and the result is exactly the same:
a from scratch USB install of 02 03 and 04 on the Pi 2… same result 02 and 03 leave me with a blank screen and just an underline cursor and 04 results in the message:
waiting for root filesystem device /dev/sda1
Fatal Error: could not find root file system /dev/sda1 - if this is a USB install please check the USB drive is connected.
OSMC initramfs Rescue Console.
for help and support see https://osmc.tv/
/#_

To confirm again… If I install 2018-01 everything works fine… It sees the hard drive and boots normally. But with 02 03 and 04 I get the above failures.

This is something to do with faulty USB install routine. There’s something missing somewhere.

I’m now going to try a USB install to an 8Gb memory stick instead of the hard drive and see if that boots.

Will report any further results here later.


#11

OK… Found the problem Sam… But it’s one where you might not be willing to fix it.

The fault does lie with your images… since version 2018-02 the USB install is not supporting an IDE hard drive. If I install to a USB memory stick as a drive, then it works.

If I Install to the Hard Drive connected to USB it fails every time to be able to see it on re-boot. even though it was able to see it format it and write the files to it during the install. (I’ve tried two different hard drives this afternoon from different manufacturers to confirm this.) This happens on any version above 2018-01 Almost as though it’s failing to mount the drive after the re-boot.

Thanks! but please consider this to be a bug report now. Because it is an issue with your images.

The only upside for me at the moment is it has forced me to open the box up and start using the Pi2 instead of the Pi1 and the response time is significantly better. Video is no different of course but everything else is a bit snappier.

Thanks!


#12

There shouldn’t be a difference between the two in the eyes of OSMC.

Maybe your hard drive spins up too slowly to be detected by OSMC in time. You could try adding rootdelay=15 to cmdline.txt to see if that gives it enough time.

Just tested Pi1 and Pi2 installs of 2018.04-1 on an OSMC PiDrive using the proper power supply without issue

I would wager that if you attached a keyboard and ran ls -l /dev/sda you’d see the drive, which means that it’s simply slow to spin up


#13

Sam I so wish that was the case… but sadly it isn’t Because the hard drive has a separate PSU I can get it started and up to speed before powering up the Pi. Once it’s spinning and done its initial check, and I then power up the Pi the result is the same. It still can’t see the drive.

In any case, it’s already spinning when it does the reboot during the install and doesn’t spin down before doing that.

Not to mention that the installer does see the drive… formats it, writes the software to it, and then re-boots and only on the re-boot or any subsequent start up the OS suddenly can’t see it.

So sadly while that’s a good idea, it isn’t the answer.

install 2018-01 or before and it works… install 2018-02 or later and it doesn’t


#14

I’ve tested 2018.04-1 on both Pi 1 and Pi 2 here with success.
You’d need to follow the instructions suggested about and see if you can see the disk from the recovery console; otherwise I won’t be able to reproduce or fix the problem.

Many thanks


#16

OK Sam I’m assuming that by instruction you mean, adding rootdelay=15 to cmdline.txt and attaching a keyboard and typing: ls -l /dev/sda I will be able to do that tomorrow morning, and will report back here after that.

Many thanks.


#18

Thanks. I assume you’ve also checked that the OS files are indeed being written to the drive?

Sam


#19

Hi Sam,
Yes during the install it can see sda1 and formats it and coppies the files to it without error. But once it reboots it can no longer see it.

Changed the command line text to : root=/dev/sda1 rootfstype=ext4 rootdelay=15 rootwait quiet osmcdev=rbp2

result was:
Fatal Error: could not find root file system /dev/sda1 - if this is a USB install please check the USB drive is connected.
OSMC initramfs Rescue Console.
for help and support see https://osmc.tv/
/#_

attached a keyboard and typed: ls -l /dev/sda
Result was:
brw------- 1 0 0 8, 0 Jan 1 00:00 /dev/sda

so it’s still not seeing the drive after reboot… this I gues begs the question of what is different between the boot of 2018.01 which works and 2018.04. which doesn’t.

Thanks!


#21

That means the drive is being detected
Do you have an sda1?

If you do then you could try mounting it and seeing if you can then boot


#22

OH OK… Ermmmmm… at this point I’m lost Sam… Please keep in mind that I’m just an end user and not very conversant with Linux at all.

What I typed out there is there only thing that comes up on screen, after typing ls -l /dev/sda

I can follow instructions to achieve things Sam, but they do need to be specific. I don’t understand most of what I’m doing with this. If you can tell me what to type, I’ll type it.
Many Thanks.


#23

Then why not simply install to sdcard rather than fool with all this?