Mount fstab based NFS share on RPi 3B+ and Synology NAS

Hi there,

I’m trying to mount an fstab based NFS share using this guide. I’m using a Synology DS411j NAS (DSM version: 6.2.3-25426 Update 2) and an RPi 3B+ with OSMC 2020.06-1. The NFS share on the Synology NAS ( works fine - at least it can be seen (and browsed) from another RPi 3B+ with Kodi 17.1 installed through RetroPie, so I don’t expect the NAS to be the problem(?). Sharing via SMB works fine for both RPi’s.


Any help/guidance is much appreciated.



EDIT: The one RPi 3B+ which I though was working - didn’t.

show the output of:

showmount -e

1 Like

root@osmc:~# showmount -e
clnt_create: RPC: Port mapper failure - Unable to receive: errno 111 (Connection refused)

Means you need to check your server configuration

1 Like

Thanks fzinken, appreciate it. I guess you refer to the (Synology) NAS? Sorry for dumb questions, I’m not very experienced in this kind of set-up. Weird thing, that I’m able to access the NFS share without problems from the other RPi 3B+ with Kodi 17.1(?)

What is showmount on that device showing?

1 Like

Holy cr*p, I feel pretty dumb now :frowning:
Same message. So sorry for misleading you :confused:

EDIT: I guess it’s the NAS configuration then(?), as you pointed out, @fzinken. Different versions of NFS? or not?

So. What have you specified in DSM (on the Synology) for NFS permissions for your target folder? I am wondering whether you have only specified the address of the working pi and have not included the new one

1 Like

Hi billat29,
First of all, thanks for taking your time to reply.

I basically followed the guide here by Synology.
In the “File Services” I have enabled NFS (although not NFS 4.0/4.1).
In the “Shared Folders” I have the following NFS Permissions for the specific folder:
Hostname or IP: *
Privilege: Read/Write
Squash: Map all users to admin

And I have selected:

  • Activate asynchronous
  • Allow connections from non-privileged ports (ports higher than 1024)
  • Allow users to access sub-folders

Hope it makes sense.

EDIT: So to answer your question, I guess that I allowed all addresses using the asterisk (*).

Do the mounts work on the other Pi? Is it also using fstab?

What does your /etc/fstab look like on the working Pi (if it’s using fstab)?

1 Like

Hi @bmillham, the other RPi does not work either - I was mistaken.
Also, that second RPi (which I thought was working, but it didn’t) was not set up using mounts. Its NFS was configured in Kodi directly instead. Hope it makes sense, otherwise let me know.


Are the kodi mounts working on the 2nd pi?

If so Whats the output of showmount -e on the 2nd pi?

Thanks Tom.

So neither Pi is working now? Did you verify the NAS IP, maybe it changed if it was working before on the Pi using Kodi mounts.

Otherwise, maybe an update to the NAS has happened? Have you tried rebooting it?

OK. Here is the output of showmount on my system:

osmc@osmc:/$ sudo showmount -e
Export list for
/volume1/MusicVideo 192.168.1.*/24

This is showing all the NFS enabled folders on my Synology and which devices can connect.
If I do this:

osmc@osmc:/mnt$ sudo showmount -e
clnt_create: RPC: Port mapper failure - Unable to receive: errno 113 (No route to host)

and that happens because there is no device at that address.
However if I do this:

osmc@osmc:/mnt$ sudo showmount -e
clnt_create: RPC: Program not registered

This address exists but it is not running an NFS server.

This is a long way round of saying that in your case, you are talking to a valid NFS server but the error 111 does actually mean that it is the server refusing the connection.
So we need to look at your Synology.

First. Is the firewall off?
Control Panel>Firewall

No idea if this will help, here is the NFS set-up for my Synology video share. I only use Kodi-mounted NFS, never had issues requiring kernel mount. The “Map all users to guest” for the Squash setting only works for me because I have configured the guest account to have access to the video share. But previously I used Map all users/root to admin and that worked too.

… and would you mind going back to Control panel>File Services and making sure that “Enable NFS” is still ticked?

No, the Kodi mount is also not working anymore, and the output of showmount -e is exactly the same for the two RPi’s.

Yes, none of the RPi’s are working. The NAS IP is fixed in my router and I can ssh to the NAS from my Windows 10 PC.

There has not been any Synology DSM update. However, I just tried rebooting, and IT WORKS!
I thought the reboot trick was a Windows-only solution. Apparently not.

So, it seems the NFS server stability of Synology DSM 6.2.3-25426, possibly in combination with the the Synology DS411j, could be … better.

Anyway, a huge thanks to all of you who helped sorting this out. Really appreciate it. And I learned a lot from this.


Or possibly you had a power glitch that can cause unpredictable results with any computer that is not connected to a battery backup.

Glad it’s sorted. I did a little testing with a new instance of Synology DSM and I thought I would post the results here in case anyone else stops by later with the same problem.

If you have followed all the steps in the tutorials and your mount isn’t working, try these steps.

My test system is at and I am trying to share the folder “Data” with “any” IP address (*)

if you enter

showmount -e

You should get something like this:

Export list for
/volume1/Data *

If you get

clnt_create: RPC: Port mapper failure - Unable to receive: errno 111 (Connection refused)

then the NFS service isn’t running. Check that Enable NFS is ticked in Control Panel>Services. Reboot if it is ticked. Try again.

If you get

Export list for

then NFS is set up but you haven’t set NFS permissions for any folders.

If all that looks good then you can try to mount the share manually just to test

me@mypc:~$ sudo mkdir /mnt/test
[sudo] password for me:
me@mypc:~$ sudo mount -t nfs /mnt/test

As there is no error we have probably successfully performed the mount. We can test this by listing the directory

me@mypc:~$ ls /mnt/test
‘Scanned Document.png’

and then we can clean up:

me@mypc:~$ sudo umount /mnt/test
me@mypc:~$ sudo rm -r /mnt/test

1 Like