Mount.nfs: requested NFS version or transport protocol is not supported)

I get the following error (mount.nfs: requested NFS version or transport protocol is not supported), when trying to create an nfs mount in fstab. I’ve tried the ntf version 3 and 4 as well, but that doesn’t seem to work.

I have used this super simple guide to setup an nfs share on my windows 10 pc, maybe this is the issue?: [How To] Add NFS server capabilities to Windows (free)

Showmount -e ip address does show my shared folder though, so the connection is there.


I’ve moved your post to a new topic, as the topic you posted in was down a miss addressing; rather than an NFS Issue.

Could you please provide logs:

grab-logs -A

Also please provide the output of showmount -e

Thanks Tom.

1 Like

You cannot connect to NFS version 4 on a Windows server that is using the built-in NFS service with only nfsver=4. You must also use minorversion=1.

I can’t recall if version 3 is enabled by default by the Windows NFS server or not. If you want to use version 3, you need to make sure it is enabled, and change your fstab entry accordingly.

1 Like

Thanks Tom,

Grab logs output:

showmount -e output:

root@osmc:~# showmount -e
Export list for
/D/HDR *

I can add it manually by the way, by adding the ip address as an NFS source…but that is not the proper way right?

This link points to a piece of code, WinNFSd.exe, which states:

WinNFSd is a Network File System V3 (NFS) server for Windows.

You can use any NFS client to mount a directory of Windows and read/write files via NFS v3 protocol. It is useful when you usually access files of Windows on Linux and for especially for virtual machines, since it is much faster than shared folders.

So you’re restricted to NFSv3. As to why it doesn’t work, that’s another matter…

1 Like

Currently my line in fstab is: /mnt/D/HDR nfs noauto,x-systemd.automount 0 0

adding version nfsver=4 or 3 does not work.

If your showmount command returns

Export list for
/D/HDR *

then the fstab line should read something like /mnt/D/HDR nfs noauto,x-systemd.automount 0 0
1 Like

Thanks Dill, I’ve adjusted the fstab, but it’s still the same:

root@osmc:~# sudo mount /mnt/D/HDR
mount.nfs: requested NFS version or transport protocol is not supported


You could try:

nfsvers=3 /mnt/D/HDR nfs noauto,x-systemd.automount,nfsvers=3 0 0

If that doesn’t help, please issue:

sudo mount -v /mnt/D/HDR

and post the output.

Thanks Tom.

1 Like

It seems to work, I’m not getting the error anymore. This is the output of sudo mount -v /mnt/D/HDR:

root@osmc:~# sudo mount -v /mnt/D/HDR
mount.nfs: timeout set for Mon Dec 17 22:30:38 2018
mount.nfs: trying text-based options 'nfsvers=3,addr='
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying prog 100005 vers 3 prot UDP port 1058

What is the correct way to add it as a video source in kodi now, presuming it’s working?


if you issue:

ls /mnt/D/HDR

Do you see your files?

Browse to Root filesystem, mnt, D, HDR

Thanks Tom.

1 Like

Well, thanks guys, it’s working flawlessly.

I can now play the jellyfish bitrate test file without hickups, so this is certainly a big, big improvement in speed.

1 Like