Mount Vero's ext USB hdd on another Linux box

So, I got an external, powered HDD attached to the Vero. I can access it from another Linux box via ssh/sftp. What I want though is a persistent mount of the drive on this other PC at startup. I tried it with NFS, SMB (cifs), fuse.sshfs via /etc/fstab but to no avail.
As long as I had this HDD attached to the router I could easily mount it persistently via nfs or cifs

Any ideas what I’m missing. Thanks

Well to answer that question we need to understand what is your problem when you try to persistently mount it from your PC?

Hi, I get different error messages. Mainly, I’d need to check again later, the mountpoint stays empty. At some point I got something w/ re to root privileges depending on the protocol.
Would it make sense to copy the fstab line here?

You can do that.
Also recommend to read this two threads for ideas what might be wrong

This thread is about OSMC as a client but surely this method works in exactly this way on any linux PC

So I tried it with
osmc@ /media/thomas/Fotos fuse.sshfs delay_connect,reconnect … …
that did not work

Well not a sshfs expert. But I assume you have proper keys for osmc user and the user mounting has access to them?
Check logs for issues.

Alternatively use cifs as it should be straight forward with user/password approach.

I tried it also with cifs - to no avail

// /media/thomas/Fotos cifs credentials=/home/thomas/.smbmedia,iocharset=utf8… …

Well well well, you really need to provide more details if you want this to be solved.
Check and share your logs.

Also for cifs allways do one step at a time.
Install smbclient on your PC and run smbclient -u osmc -L and share the output.

But one thing first, did you try the share without folder //

What password are you using? Are you aware that the SMB password is different to the SSH password?

need some time before I’m back to that network, and yes @jb2cool I’m aware of it i’m actually using an SSH key for sftp. Will report back… I’ll also install nfs support or ftp if things don’t work out with smb

hold on, I was too fast, @jb2cool where would I set this smb pwd? smbpasswd but what’s the initial username:pwd. Is it osmc:osmc?

Yes osmc/osmc is inital but you can always reset with sudo smbpasswd

boy, this is strange.
HDD1 can be mounted
// /media/thomas/Test cifs credentials=/home/thomas/.smbcredentials_osmc 0 0

HDD2 can’t be mounted
// /media/thomas/Test1 cifs credentials=/home/thomas/.smbcredentials_osmc 0 0

I get mount error(2): No such file or directory but I got smb://osmc.local/toshiba%20ext/Test

So, HDD1 works fine, HDD2 doesn’t, any idea what i’m missing here?
I can access HDD2 through SMB I just can’t mount it locally.

fstab has its own escape syntax. Instead of




OMG, it worked. Thanks a million.