Mount via fstab stopped working after upgrade to 2021.08-1

Hi all,

my mounted drives do not show up any more. I am mounting via fstab. I am not just running osmc but also nextcloud and pi-hole on the device. (Raspi 3)

What has changed:

  • the router where the harddisk is connected to has not changed, no SW upgrade
  • osmc was on the October patchlevel from 2020

I executed via command line the following:

sudo apt-get update
sudo apt-get dist-upgrade

Now OSMC got upgrade to version 2021.08-1

My mount command is the following:

// /mnt/mount_fritz/ cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=XXXXX,password=XXXXX,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,vers=3.0 0 0

Any idea what might be wrong? Were can I get proper logfiles? I checked already in


but have not found anything interesting.

Any help is much appreciated.

Thanks a lot.


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I now uploaded the requested logs. I just manually sanitized the logfile a little bit more. But I just deleted some sources and removed the user/PW from the fstab area, nothing else has been changed.

Well seems it is mounted

//  3.7T  3.5T  151G  96% /mnt/mount_fritz


According to the log the share is mounted the log is reporting:

mnt-mount_fritz.automount: Directory /mnt/mount_fritz to mount over is not empty, mounting anyway

I’d try unmounting and checking and removing the files /mnt/mount_frits

Is is it no longer appearing under Videos → Files?

Thanks Tom.

This is really strange. I now deleted the whole mount point folders. after recreating “backup” and “mount_fritz” folders now the mount itself is working but I only can access the first folder level within the share. If I want to navigate further down the structure this does not work. I am testing directly on command line.

The same folder is also connected on my Windows 10 laptop. From there I created a TXT file on the root level of the share and this file shows up immediately but not any content of the sub-folders. I even changed to root via “su” to be sure that I have all permissions.

Main hierarchy:

root@osmc:/mnt/mount_fritz# ls -l
total 1
drwxrwx— 2 osmc osmc 0 Oct 14 06:55 Serien
-rwxrwx— 1 osmc osmc 0 Oct 16 12:57 test.txt

navigation to Serien does not work

root@osmc:/mnt/mount_fritz# cd Serien/
bash: cd: Serien/: No such file or directory

Any idea?



What’s the output of:

ls -l /mnt/

Thanks Tom.

root@osmc:/# ls -l /mnt/
total 0
drwxr-xr-x 2 root root 0 Feb 14 2019 backup
drwxrwx— 2 osmc osmc 0 Oct 16 12:57 mount_fritz

but these permissions where somehow automatically changed. After creation of the folders I did:

sudo chown osmc:osmc backup/
sudo chown osmc:osmc mount_fritz/
sudo chmod 777 backup
sudo chmod 777 mount_fritz


I would try recreating the mount points again, do not set the permissions; these should be set when mounted.

Thanks Tom.


thanks for suggesting but unfortunately the result is still the same. I see the folders but I am not able to open it as I get the error message “ls: cannot open directory ‘.’: No such file or directory”

I will now install a fresh ISO on a second SD card to see if this would solve the issue. But this would be a mess for me as I have a lot of other stuff in parallel to OSMC running on that installation. To get everything re-installed/configured would take 1-2 days and I would rather like to avoid this…

Hi all,

I did exactly the same steps now with two OSMC versions. Complete fresh installation from the images, no additional config or installation of any other software.

  1. created (sudo mkdir xxxx) the folders for the two mount points in /mnt without changing owner or permissions
  2. added the two mount commands (see my first posting) to /etc/fstab

2021.08-1 => it does not work
2020.11-1 => works perfectly

So something must have been changed within OSMC for Raspberry 3 between these two versions that prevent the mount command to the performed / interpreted correctly.

Do you have any idea what might have changed here in regards to mounting? Different logic within the kernel? How can this be fixed?

Thanks a lot.


Tombar, I’m having a similar issue. My Asustor NAS is mounted via fstab as well. Has been working well for years, I have 2 Vero devices running. About 10 days ago I upgraded to August 2021 build (via command line upgrade) and everything seemed OK. However yesterday both Vero’s stopped working. When I click on any movie, which would usually bring up the information for the movie screen, the whole unit freezes and needs to be rebooted. Strange that this happened to both Vero 4Ks at the same time. My laptop and other devices can access the NAS just fine and I’ve rebooted the NAS just for good measure. No change.

Here are my logs:

The upstairs Vero -

The downstairs Vero before doing an update this morning -

The downstairs Vero after doing an update this morning -

Not sure if this is helpful or not, but if I go to VIDEO > FILES the unit doesn’t freeze but it just gets stuck with the loading circles rotating around forever and I can’t exit out or anything so here is the log after doing this -

Strange that this happened now all of a sudden and not immediately after upgrading to Kodi 19 about 10 days ago?

Would be suprized if it is same issue as you are using nfs to access the NAS compared to cifs/smb that @Tombar is using /mnt/Server_Movies nfs


why you’re giving directory and file permissions 770 in fstabwhich is rwxrwx---?

no idea (I do not remember) why I added this. It worked just fine for years. I think I took the decision years ago. I now completely removed it for a test and added 0777 for a second test. Nothing helped. With both settings I can see the folder but I am not able to access it.

this is getting really wired now. I am one step further but have not achieved the main goal.

It works if I perform a manual mount once the system is started (I moved user/pw to a credentials file) - option “noserverino” is also important. Without the files are visible but not accessible.:

sudo mount -t cifs -o rw,vers=3.0,noserverino,uid=osmc,gid=osmc,credentials=/root/.smbcredentials // /mnt/mount_fritz

But if I try the following both mount options via it does not work:

Option 1:

// /mnt/mount_fritz cifs rw,iocharset=utf8,vers=3.0,noserverino,uid=osmc,gid=osmc,credentials=/root/.smbcredentials 0 0

Option 2:

// /mnt/mount_fritz cifs systemd.automount,noauto,rw,iocharset=utf8,vers=3.0,noserverino,uid=osmc,gid=osmc,credentials=/root/.smbcredentials 0 0

Checking the status via results into two different messages:

osmc@osmc:/mnt/mount_fritz$ sudo systemctl status mnt-mount_fritz.mount

Output for Option 1:

  • mnt-mount_fritz.mount - /mnt/mount_fritz
    Loaded: loaded (/etc/fstab; generated)
    Active: failed (Result: exit-code) since Tue 2021-10-19 19:14:14 CEST; 2min 42s ago
    Where: /mnt/mount_fritz
    What: //
    Docs: man:fstab(5)

Oct 19 19:14:13 osmc systemd[1]: Mounting /mnt/mount_fritz…
Oct 19 19:14:14 osmc mount[360]: mount error(101): Network is unreachable
Oct 19 19:14:14 osmc mount[360]: Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
Oct 19 19:14:14 osmc systemd[1]: mnt-mount_fritz.mount: Mount process exited, code=exited, >status=32/n/a
Oct 19 19:14:14 osmc systemd[1]: mnt-mount_fritz.mount: Failed with result ‘exit-code’.
Oct 19 19:14:14 osmc systemd[1]: Failed to mount /mnt/mount_fritz.

Output for Option 2:

  • mnt-mount_fritz.mount - /mnt/mount_fritz
    Loaded: loaded (/etc/fstab; generated)
    Active: inactive (dead)
    Where: /mnt/mount_fritz
    What: //
    Docs: man:fstab(5)

For the first option the network seems not yet to be loaded. That I understood and added “systemd.automount,noauto” to the options. But it does not help. I do not really see an error there but the mounted folder is just empty. No folders visible at all (also not as root)

Anyone any idea?

Thanks a lot.


Have you got wait for network enabled in myosmc?

It may also be worth looking at autofs:

Thanks Tom.

1 Like

Yuhuuuuu…this “wait for network” solved the issue in combination with the following mount command.

// /mnt/mount_fritz cifs rw,iocharset=utf8,vers=3.0,noserverino,uid=osmc,gid=osmc,credentials=/root/.smbcredentials 0 0

Very easy, but it took a while. Thank you so much for this great tip.


1 Like