Mounted network drive no longer mounting

I’ve been using these forums and other people’s previous help requests to set up my RPi2 with OSMC, with a mounted network drive with my media.

It all worked great. Got my media loaded and was watching bits here and there. As it was all working I exited out of OSMC and logged in to the command prompt. tried playing around with some remote control stuff, then decided to go back in to OSMC by rebooting.

That’s where it went all wrong, and I can’t find the solution through searching. So I have to ask for help now.

After hitting the sudo reboot command, on the screen came something about unmounting from the network drive - I can’t remember what, and haven’t been able to get it again - with a clock counting up and 1:30 after the counting clock. The left hand side had something moving left and right repeatedly over a few characters’ space, and I think it was meant to resemble an explosive type thing. I think.

Anyway, after about 20 or so seconds, whatever the problem was was overcome, I think I recall something else about unmounting being displayed and it switched off and rebooted.

But I’ve not been able to mount the network drive since. I’d rebooted several times before when I was setting and mountnig up the network drive to know that it previously did mount ok on reboot.

I’m mounting using fstab, with this entry:
// /mnt/media cifs x-systemd,automount,noauto,password= 0 0

In OSMC trying to add more content via browsing the root directory to /mnt/media, clicking on the media folder does nothing. Doesn’t open up or anything.

In the command line changing directory to /mnt shows the media folder, but if I try to change to that folder, I get the error:
-bash: cd: /mnt/media/: No such device

I’ve tried deleting the folder, which I could only do by changing the fstab entry to another folder, and rebooting. the drive didn’t show as mounted in the other folders I tried either.

So I can’t mount in the folder I want, nor in any other folder I create.

Previously when I was using the wrong fstab code, I was getting a mounting failure error during the boot sequence, but with the above code it mounted fine and got no errors. Even though it is not mounting properly now, I still don’t get any errors showing on boot.

I’m running OSMC on a RPi2, the OSMC was compiled 9 April 2015, OS: OSMC 0.9.9 (Kernel: Linux 3.18.10-1-OSMC)

any other info you need that could help with this problem, let me know and I’ll try to get it asap.
I’m not very linux literate, so forgive me if I come across dumb at times.


Bly fing hell!!

How come it is always within a few mins of putting something out in the public that you notice what the problem is.

Daughter has ever so slightly unplugged network cable from RPi2 so that from anywhere other than right next to it, it looked plugged in, but wasn’t…

Surprise, surprise, plug it back in and everything works…

Mods - please feel free to remove this whole topic…