Mounting hfsplus and fstab

Hi there,

For some reason, my hfsplus drive is mounting ro. I have fsck’ed it, and still that’s what’s happening.

I would iike to mount it rw. Any clue?

And does anyone have an example of an fstab line to make it mount automatically after reboot? I tried one, but always get a sintaxe error.

All the best,


Linux does not support mounting a Journaled HFS+ volume read/write, at least not safely.

As Mac OS X by default (for many years now) has formatted HFS+ volumes with journalling enabled, this is a problem.

If it is an external data drive (for Movies etc) that you need to move back and forth between the Pi and a Mac you could format it as HFS+ without journalling and it should mount read/write. (I have not tested this however)

Or you could use EXFAT / FAT32 which are supported for read write for both Mac and Linux.

One final possibility if you can’t reformat the drive, is that you can force remount the drive as readwrite using -o remount,rw, however this is not recommended as it can lead to data loss, and we don’t provide any automated way to do this at the moment, so you would have to do this manually every time the drive was attached, or script something to do it - making the entry rw in fstab is not enough.

Thanks again, DBMandrake.
I’ll check if it is a journaled volume - but I can say already that under Raspbmc, the same volume worked fine with rw, and were on fstab and automounted normally.
I tried the -o remount,rw, it didn’t work somehow.

There are a lot of difference between Raspbmc and OSMC.

Raspbmc only had a 3.10 kernel, OSMC was using 3.18 and now 4.1 kernels.

Raspbmc was based on Raspbian, OSMC (on Pi 2) is based on Debian, so the user space is also different.

Sorry I should have been more clear, -o remount,rw is an option to the mount command to remount an already mounted partition as read write. You wouldn’t add this to fstab.

Thinking about it there may actually be an override option you can put in fstab - try adding force as one of the options.

Hi DBMandrake,

Sorry, I should have been more clear myself - I tried the -o remount while the drive was already mounted, as you said. I didn’t put that on fstab. And it remounted, but only ro.

Could you please tell me what is the syntax for the fstab line? I tried twice, once with /dev/sda2 and another with the UUID info, and was getting parse errors.

I added this to my fstab:

UUID=184ac917-ec86-32f6-9ebe-2607409919f0      /mnt/Backup\040Seagate  hfsplus  force,rw,auto 0   0

But it still doesn’t mount it rw. However, when typing
mount -o force /dev/sda2 /mnt/dir
then it works perfectly.

A couple of days ago I was also trying to mount /boot as rw. I couldn’t do it not matter if I tried to ‘-o force,remount,rw’ or if I unmounted and then mounted it as rw. It just wouldn’t take.

I commented out the entry for /dev/sda1 in /etc/fstab rebooted and at some point my efforts born fruit! I was able to mount it rw and change some settings.

A day or so later I unmounted it, uncommented the entry in fstab and mounted it again as ro. Well, I have not been able to repeat this again. No matter how many times I tried today I just cannot mount it as rw.

I also tried mounting /dev/sda1 on a different mountpoint under /mnt/ and it still mounts as ro.

Is there a way to work around this problem? I need to copy a kernel to /boot and I am stopped from achieving this.

umount it first as you did

then fsck.hfsplus /dev/sda1 (/dev/sdb1 if usb install)

I tried to get in touch with you in IRC, but we kept missing each other


Yes, I’ve been running around lately trying to fit in too much. :wink:

Thanks Sam, this worked a treat. It appears that the fs was corrupted. All good now.