Mounting Vero MicroSD (Windows or Ubuntu) - December update

#1

Having received the update notification on my Vero yesterday, I set the December update installing & left it to run. Few hours later, I tried to ssh to the Vero & got no response. Tried checking the TV interface, and the TV suggests checking the HDMI cable. If I power cycle the Vero, the TV responds to some change of state on the HDMI signal, but whilst the optical port on the side shows a red light to give me some hope the device is at least trying to work, it never registers itself on the network, and doesn’t output any signal to the TV. Sadly, because I couldn’t contact it in any way, I haven’t been able to get logs from it.

I suspect a fresh install to the Micro SD will do the job, but I’d really like to try getting the data off the card first: can anyone please advise how I can mount the card? I’ve tried the Disks utility in Ubuntu and the mount options are disabled. In Windows, I see a small partition auto-mounted that appears to be the OSMC install, but not the main body of the data.

Aware I’ve previously had issues on updates, so I’m more than happy to be educated if someone wants to suggest where I’m going wrong!

0 Likes

#2

Have you run it as root? While actually the card should automount on Ubuntu

0 Likes

#3

I would also give GParted Live a chance, see https://gparted.org/index.php where you can find a bootable cd image. If that doesn’t work or gparted cannot repair, it sounds like a corrupt/defective SD card since you claim to have such issues long before.

1 Like

#4

As @fzinken has said, the card should automount, but even if it hasn’t been mounted it should have been detected by Ubuntu.

If you run sudo fdisk -l from the Ubuntu command line, do you see anything like /dev/mmcblk0p1 and /dev/mmcblk0p2 being listed?

1 Like

#5

I have now you’ve suggested it, thanks. Sadly, same result: I can see a single volume, with disabled mount options under the double cogs menu.

Thanks for that suggestion: it seems to have been enough. Booting into GParted Live showed me two partitions on the SD card. I tried the ‘rescue data’ option, and once I booted back into Ubuntu, I could read the card without issue

Following Jim’s suggestion (and presumably, GParted working some magic), I do, yes: full output below (excepting that the “Partition 4…” line is in red, and I don’t think I can do that in preformatted box), with separation for pre- & post-GParted clarity

Prior to GParted examination of the card:

Disk /dev/sda: 698.7 GiB, 750156374016 bytes, 1465149168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x000baca2

Device     Boot      Start        End   Sectors   Size Id Type
/dev/sda1             2048     497663    495616   242M  7 HPFS/NTFS/exFAT
/dev/sda2  *        499712     704511    204800   100M  7 HPFS/NTFS/exFAT
/dev/sda3           704512  899231179 898526668 428.5G  7 HPFS/NTFS/exFAT
/dev/sda4        899231742 1465147391 565915650 269.9G  5 Extended
/dev/sda5        899231744 1457002495 557770752   266G 83 Linux
/dev/sda6       1457004544 1465147391   8142848   3.9G 82 Linux swap / Solaris

Partition 4 does not start on physical sector boundary.

Following GParted I see the above, but also

Disk /dev/mmblk0: 59.5 GiB, 63864569856 bytes, 124735488 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xfe5d891e

Device       Boot  Start       End   Sectors  Size Id Type
/dev/mmblkp1        2048    499711    497664  243M  c W95 FAT32 (LBA)
/dev/mmblkp1      501760 124735487 124233728 59.2G 83 Linux

Slotting the micro SD card back into the Vero after this didn’t magically restore the OSMC install to a fully working order, but I have the data, and a fresh install has got the Vero up & running again. It’s also made the ext4 partition inaccessible again, but I can live with that: hopefully I’ll be able to restore the database over the network. Thanks all.

0 Likes