Mouse icon not working

I installed OSMC on my Raspberry Pi. It shows the mouse icon as a strange line. I can’t figure out how to fix it. I see it in different skins so it’s not the one that i’m using that’s causing the problem.
Here is a screenshot of my issue.

Please Fix!

It’s not a widespread problem as you are the only person reporting the issue. It’s apparently something local to your installation. There is nothing OSMC can do to fix. Either try rebooting a few times or re-install.

That happened to me also a while ago. I reinstalled OSMC and all is fine now.

Without a log, no idea what the issue is, nor can we confirm that there is an issue to be fixed.

There were mouse pointer issues on very old versions of OSMC. Make sure you are up to date.

I just received an update today. I usually check for updates every 2 days so I am definitely up to date. My log is here: http://paste.osmc.io/jetasuhina
It fixed it’s self after updating, although it appears to be broken again (as i’m typing).

Your log does not show you on the latest version of OSMC. I assume it was captured before updating.

Nothing obvious in log. Is the PSU good? I can see you have a WiFi adapter attached.

That is correct. I can have it generate a new log if you want. It’s currently running on an Apple iPhone PSU. I assume that is “Good”. Yes I do have a wifi adapter.

For the purposes of providing power to a Raspberry Pi, Apple iDevice chargers have proven again and again to not be up to the task.

An iPhone charger is not sufficient

Ok. What kind of charger is sufficient?

https://osmc.tv/store/product/raspberry-pi-power-supply/

Ok. I ordered a 5v 2.5A power supply. I just tried it on my pi and am having the same issue.

Maybe HDMI cable issue. You could install VNC server to exclude the HDMI cable from the equation. If it is visible on VNC it is not an HDMI problem.