Mouse stopped working


5 days uptime and after turning TV on mouse movement undims the screensaver but mouse pointer is missing… cant choose any menu item from the main screen(skin confluence)

I tried another dongle (hotplug) with keyboard+another mouse but no difference… no reaction to keyboard or mouse movement… only choice SSH in and sudo systemctl restart

Full debug logs

PS. This is the first time i’ve encountered this kind of problem(no changes in HW only normal OSMC updates via My OSMC/Updates)

Hotplug is not gonna be recommended for any hardware. Is this still an issue after reboot?

No after this issue i did above mentioned command line sudo systemctl

Then pretty much left my RPI2 all alone in debug mode+TV switched off…

(and i created another thread what happened next… sad face) <- Just to make clean did not happen after restart but later on… i’ve had no problems after restart/reboot… only after day/days of uptime

But all 2 i’ve reported have only happened once so far

Ok. i’ll stop reporting problems in the future :wink:

Are you saying that restarting Kodi brings the mouse back up? I know this used to be required for keyboards, but changes to CLinuxInputDevices mean this doesn’t need to be done anymore.

Mouse pointer on Pi is done in the GPU now for performance. It’s possible there is a change in default behaviour as a result of this


I’m not saying stop reporting issues, but hotplugging hardware is a KNOWN problem with a device that barely passes enough current to keep itself running, much less run peripherals.

Yes it did! sudo systemctl restart mediacenter made mouse working good again=pointer seen and possible to choose items

Yes i said i did hotplug another dongle AFTER the problem just to see if its a problem with one i am using = logitech… anyway i dont think its the most important issue… it didnt have any effect anyway…

But i could not do anything using mouse from the screen but only from SSH=sudo systemctl

And besides i am using 2.1A supply so i never seen any low current blocks in the screen

Full disclosure: I am NOT an electrical engineer, but I have been using Rpi since rev1.

When we are considering the whole system operates on 5v, hotplugging peripherals should not be seen as an acceptable method of adding hardware. The amperage supplied by the PSU makes no difference as you are requiring the Pi to suddenly accept/pass a huge (compared to it’s own running demand) amount of amperage so quickly in an instant. In such a situation, most PSU’s are likely to have issues maintaining 5v while it tries to meet the sudden demand for amperage.

Someone may get to it before I do, but at the moment, I’m unable to look into your logs from the other thread tonight. I’m happy to investigate when I have time tomorrow if someone else hasn’t before then. In the future, since all this is related, you probably could have kept it all in one thread.

Well i noticed from another threads there is complaining about separate threads should be done so i did because i really dont know if sad face and this issue are related… thus separate

And sure i can recycle power if needed but as mentioned many times on this forum too RPI1+2 are designed to be always on… but for me it doesnt matter… if needed i can recycle power

Also repeating words… when this happened i did not do any hotplugging (= i dont normally do it ever) but only tried it AFTER this issue on this thread happened

And other thread (sad face problem) didnt happen right away after the hotplugging but way later

I hope this cleared the situation

PS I very much appreciate the work you do, i’ve always done since XBMC + i only report these problems in the hope it willl make the great product even better.