Moved from WHS to Synology DS918+, advancedsettings question/help


I’m not new to OSMC, raspberry Pis or the addvancedsettings file. I have migrated all of my movies and TV shows over to my diskstation. I have 2 version 3 pis and 2 version 2 pis. I have setup mariadb 10 and phpMyadmin on the diskstation. All 4 pis running the same version of OSMC. All 4 pis have the same advancedsettings file installed on them. The 2 pi v3 functions as they should. When a show is watched of paused/stopped. the other pi v3 indicates the corrected status either watched or only partially watched. The 2 pi v2s will not updated the file status. I have never experienced this behavior before. Any help would be greatly apricated.

Thank you

mysql 3306 osmc osmc osmc_video mysql 3306 osmc osmc name>osmc_music

Are they all on the same version of OSMC / Kodi?

Yes Sam they are

Some logs might help us identify the issue.
A fresh export and re-import may also help resolve the problem


I will try the export and re-import, I’ll report on results.

With my Synology system, I run mariadb 10 through port 3307, not 3306, and all works well.

Thank you if the export inport does not work ill give that a shot/

Now after export and import, all of the Pi’s show watched shows but is not updating newly watched shows or updating partially watched shows.

I’ll enable log and post back.
I’ve enable all of the log, but which ones would be the most helpful?

My mariadb 10 is running on port 3307

Here is the tutorial I followed for set up at the Synology end, you may have this covered but providing just in case. It’s a bit dated but I read elsewhere the port should be 3307 for mariadb 10. I run a mixed environment of OSMC and LibreELEC devices and the central database is rock solid, and the family love being able to pick up playback from different rooms. You’ve probably checked you have your sources mounted identically across devices?

Ty for the link, but I used that one to set the NAS up. I’m thinking of a fresh install on all 4, start from sq one. Setup one at a time. It will not take that long.

Well a full debug enabled log doesn’t take long and may explain what’s going on.

Ok I have never attached a log file to this forum. How do i do it? I could just copy and paste the log in?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Here is the log for the primary pi
here is a log from one of the satilite pis


both logs are reporting:

13:03:26.700 T:1925372416   ERROR: Error loading special://profile/advancedsettings.xml, Line 16
                                            Error reading end tag.

So that would explain while you are having issues connecting:


should be:



Yet both logs still show:


Thanks Tom.

Thank you Tom for your reply. I will modify the advancedsettings file and report back.

When I look in my synology mariadb configuration it reports port 3307. I will recheck

EDIT I see in the advancedsettings file the port needs to be changed to 3307, done. testing now.

Thank you all, system now up and running and I learned a few things. This is a great community of helpful people. I hope to return the support.