Movie not scanning to library

Put a new remux I made with MakeMKV on my USB attached HDD but when I try to scan it to the library using the normal method it doesn’t even attempt to bring it into the library.
Then if I try to manually scan it to library I get a remote server not reachable error.
So I enabled logging, did a reboot, then tried again with no luck.
Here’s the log:
Searching for “High Plains Drifter (1973)” will probably take you to the relevant place in the log.
I see the errors in the log, but not sure why they are there.

All help greatly appreciated.
Happy Thanksgiving!

CCurlFile::FillBuffer - Failed: HTTP returned error 403

IMDB is blocking CURL request. Suggest you try another scraper

Reconfigured Universal Scraper to use and it still didn’t scan to library.
Changed folder to be scraped with the python TMDB scraper, still didn’t scan.
Tried the original TMDB, still didn’t scan.
Went to file and chose the option to scan to library and the original TMDB got it.
Weird that doing an overall scan wouldn’t get it.
I think there’s something else going on too maybe.
I’m going to try scraping some dummy files to do additional testing.

IMDB is blocking all requests that don’t include a valid browser header (that happened just recently). So the Universal scraper is definitely broken when using IMDB as a source, and it might never come back. Other scrapers have options to get IMDB ratings, but none of them depend on IMDB for core information.

As for your particular challenge, sometimes if you get a failed scrape there’s a little bit of the movie that gets stored in the database, and Kodi won’t rescan a movie it’s already scanned (based on file name). So that’s probably why you had to tell it specifically to scan that file to the library (which overrides the “don’t scan again” flag).

BTW, the IMDB thing also affects the TV show scrapers, so as of right know none of the scrapers can get IMDB ratings anymore. Unless someone has $50K a year laying around to buy access to the IMDB API, that might not change.

1 Like

Does renaming the file from High Plains Drifter (1973) Kino Lorber [DV.UHDRemux] {938CD36C}.mkv to something like High Plains Drifter (1973).mkv make any difference?

1 Like

Forget IMDB.
They can go pound sand.

1 Like

As long as you have (year), anything after that Kodi ignores, except things like .atmos and .dtsx.
The naming convention is definitely not the issue as I have 60TB of stuff scanned into my library with that convention.
Thanks for the suggestion though.

Ah, that’s why the movie “1917” sometimes has trouble being recognised.

That maybe how it should work but does renaming help in this instance?

I have that movie and it scanned in perfectly fine when I scanned it in on Sep 4th 2020.
I have it named as such: 1917 (2019) [DV.UHDRemux] {F689E726}.atmos.mkv

The problem was just that IMDb is broken now in the scrapers, so I just told my scrapers to use TMDb.
Funny thing is, by default I used TMDb from day one of owning the Vero, then something broke TMDb at some point in time so the solution was to use IMDb, now we’ve come full circle.
It’s just how things are when you rely on remote services instead of NFOs.

IMDB is a particularly inconsistent choice because all the scrapers that get data from it are doing screen scraping. So if IMDB changes their web site (which they did recently to try and keep people from scraping the web pages) the IMDB stuff tends to break. At least with TMDb (and TVDB) there is a stable API for which you register for a key. 90% of the time when one of those breaks it’s because of bad data in the site, not the actual programming.

I’m having the same issues. I guessed IMDB wasn’t working so I switched to tMDB and it doesn’t help. Why doesn’t it give a verbose error on the screen?

Will try with logging and also renaming the file…