Movie playback is intermittent

(*) The moment I start to play this particular movie (Shang-Chi.and.the.Legend.of.the.Ten.Rings.2021.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HEVC.REMUX-EVO.mkv) frames are dropped and playback is totally disrupted (both video and audio)

(*) I tried several times, the issue always appears in the same way.

(*) The file per se is totally ok: if I play it from another device (Apple iMac via VLC) it is perfect both in terms of audio and video

(*) The movie sits on a qNAP NAS, connected to my Vero 4k via RJ45 cable

(*) I cannot say if this issue is due to latest OSMC distribution, as I got it after the Kodi upgrade

(*) Logs link:

(*) Mediainfo data:

Thank you for your support


We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Thank you for the prompt response.

(*) Settings>Player>Videos>Adjust display refresh rate> On start/stop was already enabled.

(*) 4:2:2 colour subsampling enablement does not help at all :frowning:

Any other suggestion ?

Yes, did you set the resolution down to 1920x1080?

If you still experience issues, provide new logs demonstrating the recommended settings and the issue occurring.

This is a Disney+ film with atmos soundtrack and exhibits the audio drop outs discussed at lenght on the other thread. That being said, when I watched it I had no video drop outs.

I applied the resolution settings change (from 3440 to 1980x1080p) and vide playback experience did not change at all. In fact the main screen at this new setting is cutting each corner, making the UI look worse.

Please find logs here:

Hello pinn73
Do you have a Vero 4K or different player ?
Maybe you can share your Player and video settings ?



The 4k+. Just standard settings from here - Ui @1080 and using whitelist

I am not clear if I need to do anything in the whitelist section … in the earlier recommendations it should be empty

Settings>System>Display>Whitelist> (empty) *

Not sure what to do here

No, I don’t think that’s what he meant if you reread his comment. I’d set it up via the link above

Now I see what you mean … thank you … going through the link now


I went through the guide and tried both with whitelisting exactly the same settings of the movie and without whitelisting … no difference whatsoever.

Try a different hdmi cable I guess, just to eliminate that as the issue

It seems you have a issue with Overscan. Ensure that you did not have any calibration configuration in Kodi/OSMC and use one of the following methods depending on the TV Brand you use.

  • Samsung TV - go to Menu / Picture / Picture Options / Size / Screen Fit (instead of 16:9).
  • LG TV - go to Settings / Picture / Aspect Ratio / Just Scan (instead of 16:9)
  • Sony TV - hit Home button, go to Settings / Screen / Display Area / Full Pixel
  • Sharp TV - hit View Mode button, select “Dot by Dot” or “Full screen”
  • Sharp Aquos - go to Menu / System Options / View Option / View Mode / Dot by Dot
  • Panasonic TV - go to Menu / Picture / Screen Settings / 16:9 Overscan / Off`
1 Like

Thank you fzinken … tried that (my TV is a samsung 4K) but no change in the quality of the playback

That advice was just to fix the Overscan that you had when you changed to 1080p as GUI resolution.

Thank you anyway :slight_smile:

This is discussed many times, it is more than likely a HDMI cable that is not high enough bandwidth, it doesn’t need to be an expensive cable it just needs to have be the correct version. 2.0b and higher

A 4k film uses about 112-130mbyte a second, so disk read speed, network cable (or WIFI) and HDMI cable all need to be adequate spec if bitstreaming the HD audio.

If you are using an AVR then it will be two HDMI cable that need updating.

Hello jack4r
I tried a few HDMI cables that I have at home and bought on purpose a new HDMI cable from Audioquest: Carbon (4K/8K, eArc, HDR, 18 Gbps, … I am sure it even makes coffee if I give it a try … but no change. Same exact issue when I play the file.

Furthermore I had the same issue with this other file


that otherwise plays perfectly when I use my 2019 iMac.

Now, I noticed that the only two files I ever had issues with share the same codec (HEVC main 10@L5.1@high) … I am beginning to believe that maybe the Vero 4K is not optimized for this one.

Other thoughts?