Movies from SMB shares hangs often

I am using the latest OSMC release on my Raspberry Pi 3. I used OSMC shortly on my B+ model but shifted to RPi3 as soon as I received it.
I have all my movies on my Win8.1 desktop shared with SMB.
There has been no problem in adding the media content and everything works normally.
Except when I try and fastforward too often or skip by using the arrow keys.
I never faced this problem on my B+ setup and the only change between them is I am currently using the Confluence skin.
Everything remains the same, but I am frequently facing this issue. Sometimes I simply press stop and after a few secs delay it would go back to the list and I would give Resume from time…
But a couple of times the entire system hangs and I have to manually unplug the pi to reboot.

Is this problem isolated to the new pi3s, or maybe SMB isn’t best for network playbacks ?

Because as I understand, Pi3 packs more CPU and RAM than B+ and should function better.

Logs? Wired or wireless?

over wired through my 4port modem. Pi connected to my Bravia TV via HDMI.
And what logs are you asking for ? Am new to OSMC so instruction to obtain them would be nice.

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

What kind of switch is your Pi and Server plugged into ?

Does this help ?

It would be good if we could find out more about the file you are having issues playing. Please see the mediainfo section in How to submit a useful support request - General - OSMC