Movies menu item is not showing up

Hi!
Few days ago I’ve installed OSMC first time - really great, thanks! It was working well until today. I did experiments and after all - completely reinstalled OSMC (OSMC_TGT_rbp2_20151129.img). From this moment I have a problem adding my content - it just not showing up in main menu.

What I did just after fresh install of 20151129 image:

  1. Configured networking and checked “wait for network” checkbox.
  2. mkdir /home/osmc/disk1
  3. chown osmc:osmc /home/osmc/disk1
  4. mount /dev/sda /home/osmc/disk1, also I’ve added string into fstab using drive uuid (that’s my usb drive connected directly to rpi2)
  5. permissions are right (osmc can rwx)
  6. Then I just added one video file into /home/osmc/disk1/
  7. From Videos->Files->Add new file menu I added this folder with “Movie” content type
  8. Now I can see that library is updated and I see the name of my file in popup during library update process
  9. But that’s it - nothing happens after that - I can’t see my movie in Videos menu item, neither I can see “Movie” menu itself as it was before!

I’ve checked some topics with the same problem and tried to delete “.kodi/userdata/Database/MyVideos93.db”, but this fixes nothing.

PS: RPi 2B, OSMC 2015.11-2 (kernel 4.3.0…), kodi 15.2 (Compiled: Nov 22 2015)

Updated: Here is debug log: http://paste.osmc.io/sijaliqini (fully fresh bare metal installation of OSMC), nothing except network was configured, systems was updated via My OSMC menu and one “Movie” source added, but no “Movie” menu item appears - that’s a problem.

[RESOLVED] Just use right file names (http://kodi.wiki/view/Naming_video_files) and install Universal Movie Scrapper addon (of course you have to configure it first) - after that everything work like a charm! OSMC is the best, thank you!

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Sounds like the scraper isn’t understanding the video naming, or the video isn’t in the online database used by the scraper addon you chose.

Read this for info:
http://kodi.wiki/view/Naming_video_files

No, even if the name is just bla-bla-something.mkv and scrapper doesn’t have info about it online - the video was appearing in main screen anyway inside “Movie” menu item. Now my problem that “Movie” menu item is not showing up itself. To be sure I’ve reinstalled OSMC from bare metal, and nothing fixed - the same problem…
In some minutes I will upload here link to video with steps what I do from the beginning, also with the link to full debug.log.

Looks like you are right, when I’ve added new scrappers - the video appears and now everything is ok.
I’ve used Universal Movie scrapper addon - configured it, renamed the file and now it works! Thanks!

I can’t see how that could be the case. “Movies” is only movies in the Library, which is files that have successfully been scraped or had nfo files read in. If the scraper doesn’t match them they will not appear in movies, period. You will see them in Video->Files though, which is basically just a file browser.

Yes, you are right, my bad.