Movies not displaying in main Movies folder

Hi all,

I have a problem in that not all my movies are displaying in my Movies folder, however, when i selct favourites > movies, they are all there!

I use the Metropolis skin and i have tried re-scanning with other scrapers and using different skins too.

Any ideas what is causing this issue please?

Have you got the ‘Hide watched’ feature enabled? I think that would be an obvious reason for this.

1 Like

Can you direct me to this setting please?

I have this for TV shows, but never had this applied to Movies.

Found the setting and no i don’t.

However, if i delete the movie file and re-add it, it will appear in the library - strange.

Can you reproduce this behaviour with another skin, such as the OSMC skin?

I switched to the osmc skin and am still having the same issue - all videos display in my favourites folder but not in the main movies folder:

These are the movies i am having issues with:

Batman Begins/The Dark Knight Rises
Matrix 2 and 3
Men in Black 2
The Final Option
Liar liar
Little shop of Horrors
Thor Love and Thunder
Wolf of Wall Street
True Lies

Thx for the video. As far as I can see in the favourites folder, the missing movies don’t have a cover but screenshot from the video. So, means the scraper doesn’t find anything since the name of the file is missing important information or leads to ambiguous results.

Let’s assume you have configured to use the default scraper “The Movie Database Phyton” and you want to be sure the mediacenter can find Zathura using this scraper.
The related web site is and shows for the film the title “Zathura: A Space Adventure (2005)”. Try to rename your movie file from ‘Zathura.mkv’ to ‘Zathura A Space Adventure 2005.mkv’ and scan your movie folder again.


It worked for MIB 2, but for none of the others - i went onto tmdb and copied exactly what the title was on the site :frowning:

Think i’ll grab alternate d/load versions and see if that does it.

Make sure that settings>media>videos>use video tags> is NOT enabled. Additionally, if you have these movies in subfolders and your scraping options have the ‘separate folders’ option enabled then the changes needing to be made are with the folder names and the file names don’t really matter.

We are also playing a bit of a guessing game as without debug logs showing the scraping process there is limited information to go off of.

1 Like

Hope i did this right!

The setting I previously mentioned needs to be turned off as it is currently broken…
<setting id="myvideos.usetags">true</setting>

Additionally your sources do not seem to be setup correctly. You should remove the bad sources that are just pointing to smb:// and then add one pointing to /media/My Book/Dad/Movies/ and setup the scraper for that and then add a separate one pointing to /media/My Book/Dad/TV/ setup with the appropriate scraper for that source. If your unclear on how to setup a Kodi library I would suggest to check out Kodi’s wiki…

1 Like

Tags setting - i had to change from standard to advanced/expert settings as i couldn’t see this option before. But i have now changed tags to off and it worked! I can see those videos in the movies folder - thank you so much for your help.

Sources - i have folders “Movies” and “TV shows”, but recently det up a folder called “Christmas”, which using your adding video sources link, i have pointed this to the christmas folder and it is now a video library. However, as well as adding all the christmas movies to the christmas folder, it’s also added all the christmas movies to the main Movies folder.

Is there an EASY solution to resolve this? I do not want Christmas movies in the Movies folder. Someone suggested playlists, but i couldn’t figure this out.

Given that “easy” is a bit of a relative term there is an option I outlined in a howto here…

Aside from that if your skin allows for customizing the main menu items (so not Estuary) you can point the movies home screen link to your main movies source location instead of to the movie library. You could probably also just edit the node to exclude the Christmas source location and then add a new node that excludes everything but the Christmas source and then add that node as its own main menu item. Kodi only has a single library (for any given user profile) so if you want items in a library so they get metadata but don’t want to be looking at them as part of your primary collection then you have to work out some type of filter to separate them. You can search this forum for something along the lines of separating/excluding kids movies (the most common use case for this type of tweak) and you should find some solutions mapped out in some detail.

There is also the option to not have the metadata and have a source that is not scrapped into the library. You can then just browse and play from the “Videos” section. I do this myself for ‘watch once and delete’ type of content.

1 Like