Movies passthrough dolby truehd

Hello all,

I have a movie named dolby trueHD 7.1atmos
I placed it on a usb stick 3.0 connected to the vero4k+
The vero 4k+ connected to my Samsung S95B on HDMI port 2.
The Samsung TV itself is connected to bose 900 with hdmi e arc.

yet when i watch on the bose app i get lpcm7.1,
i placed on passthourgh on TV itself and on the vero 4k.

Any one has an idea what could be wrong?


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

thanks for the fast response, i will check it


Dolby Digital (AC3) capable receiver: true
Enable Dolby Digital (AC3) transcoding: false
Audio output device: ALSA:default
Number of channels: 7.1 ===> Default: 2.0
Output configuration: Best match
DTS-HD capable receiver: false
DTS capable receiver: false
Dolby Digital Plus (E-AC3) capable receiver: false
Play GUI sounds: Only when playback stopped
Allow passthrough: true
TrueHD capable receiver: false

Although passthrough is enabled, you need change the setting for TrueHD capable receiver to true.

Regards Tom.

i just got this vero 4k+ today, where do i exacly change it?

thanks i found the setting, for others it was in expert mode

1 Like