Moving from Raspbmc

Originally published at: Moving from Raspbmc - OSMC
Hi Many users are finally starting to move over from Raspbmc to OSMC, so we thought we’d write a small guide to help you get moved over with as little interruption as possible and ensure that you get the very best out of OSMC. What’s OSMC? Why is it better? You can learn more about…


Hi Sam,

Thanks for the write up regarding the transition from Raspbmc to OSMC. However, I found a word missing in the paragraph below. I believe you wanted the word “use” between the words “still” and “any” in this section: ‘can still any compatible.’

"Things look different!

With OSMC, we decided to ship a different skin that really showcased OSMC right out of the box. However you can still any compatible Kodi skins as you could with Raspbmc. If you’d like to get the classic look and feel of Raspbmc back, simply:"

Hope this helps. Feel free to delete my message if you want to keep your original forum post clean without comments.

Cheers, Jon

Hi Jon

Thanks, I’ve updated this now.


The post says:

OSMC already runs on a variety of different devices

and the link really shows some different ones. But when I use the osmc-installer (on Ubuntu Trusty), I only can choose Rpi and Rpi2. Where did I do wrong? How do I create a SD card for i.MX6?

The link says “OSMC will run on most i.MX6 devices in the future.”

Hi Sam, I have installed Osmc and everything went well, I only have two questions:

Is it normal that df command shows tempfs partitions?

Is a progress bar or text supposed to appear when installing apps from App Store?

I tried installing Samba but nothing seemed to happen, I had to install it using apt-get install samba-osmc-app for it to show as installed and work.

Tranks for making Raspbmc before and Osmc now, I’m sure it will become raspberry’s best media center distro in no time.

After you chose install for Samba you should have been returned to the main store window, did you then select Install from the lower right corner?? Or did you miss that.


Today I went and did a manual update check, which made osmc download updates (don’t know why it never prompted me, even if it was set to check daily).

After updating, I went into OSMC settings app (noticed resolution was better, no more text overlaying, and also the new “remotes” section) and chose to install FTP server. then noticed “Apply” and “Install: 1” above the “Exit” button, I honestly don’t remember seeing them before.

I guess I was missing the latest updates, now everything is working fine (FTP server installed flawlessly).

Thanks for the heads up!

Can I backup my kodi then move from raspbmc to osmc and restore kodi and retain everything as it was?

Moving your media databases is supported but, a fresh setup from scratch is going to result in the best OSMC experience possible.

Not sure if this, or the previous comment that disappeared, is a reply to me or not. I did read it said you can move your libraries. I am not interested in my libraries I am concerned about my kodi setup, skins, addons, configuration etc. Sorry if you think I am being ridiculous. I only recently moved from openelec to raspbmc then take many weeks setting everything up then raspbmc gets dumped!

You can try this and it should work, but we can only support the fresh install


Ok fresh install it is. Thanks

Yes, now it says “in the future”. It hasn’t when I wrote my comment. Seems that commit here was Sams way to reply to my question. Well, strange way, but a solution nevertheless. Thank you for the clarification.

With Raspbmc I had installed Live TV, now in OSMC it doesn’t show as an item on the menu, and I haven’t find a way to enable it…
Any suggestions about how to resurrect this configuration?

I migrated to RC2.

Decided to move from raspbmc today to RC2 of OSMC. Seemed to install fine, but I have no sound at all (videos or music). Can’t figure it out :confused: (512mb RPI1)

From a complete newbie! … and I mean complete.

I have only ever used Microsoft Windows for a lifetime.

A year ago I bought a Raspberry Pi.

Did zero with it, except to load Raspbmc and watched a couple of movies off a hard drive.

I loaded OSMC a couple of days ago and found it so easy to instal - a real dream.

I can only hope to gain some knowledge about OSMC etc and enjoy the journey.

I am not a young person at all, but while the grey matter still operates, I will use same.

Thanks for all your efforts in providing this fantastic service.


This is good to hear.

If you have any questions just make a new thread and we will be glad to help


I wonder if I have lost my library?
I followed the instructions to export my library from XBMC and chose single file. When I looked hwoever, it was actually a directory structure. I did it again, with the same result, so I assumed all was well and did a fresh install.
Now, I find I have nothing to import (I scp’d the directory structure over)

Can I recover from this?