Multiple functions do not work properly

Hey guys

Recently, I noticed that my Vero 4k+ seemed “corrupted”. Whenever I try to install updates, it says “installation failed” but goes on to install the update anyway. Whenever I try to turn it into a hot-spot, it refuses to do so.

This is the most annoying part: music now shows up as “Not Available” and files as “N/A” (see picture)

All of the logs can be found here (

Any idea what the problem could be?


You could re-install OSMC from Reinstalling OSMC - Vero 4K - OSMC.

Sounds like networking issues

@vanctardi I still believe it might be a network problem, but you might also want to try to install skin.helper addon.
via Skin Settings and chose “Enable menu customization.” This brought up the prompt to install “Skin Helper Service.”

I wanted to make a reinstall since i have a couple of issues going after being away since october 25 and now made an update around december 9 and things stared to act strange. Such as the network volume i had set for backups was not there anymore when i tried to backup settings, when i play músic it take about 20 seconds before any song start (but once its started the remaining songs in the album (folder) is found without delay). its also seem to lose connection to my USB DAC - but that could be other reasons im exploring right now. remote seems to be more unrelkiable as well though.

Anyway, i use a new imac and afretr downloading the installer app i continuously fail to make an installer USB - I tried 2 different sandisk USB sticks 8Gb and installation failed on both. I also tried different images (versions) but still failed to make the installer disk.

You may need to use another tool - there seems to be a problem with macOS Catalina for now.

But here’s the thing right. I can access internet and all the files without a problem.

I was able to download and install an update yesterday without issue, so it’s definitely not a networking problem.

Reinstalling OSMC worked like a charm, thanks.

1 Like