Multiple Installation Failure (RPi 2)

I am having installation issues on my RPi 2 (and brand new RPi 3) and cannot figure out what’s wrong so am hoping I can find a solution on the forum. By way of background I was running OSMC (with periodic updates - including to the newest 2 April version) on an RPi 2 with no issues for the last 7 months. My problem first started when I backed up my Kingston 16GB (Class 10) SD Card this past weekend using Win32 DiskImager. Immediately after the backup I couldn’t start up my RPi 2 at all. Even after formatting the SD card and writing / restoring the image file I just created, the RPi 2 refused to start. I decided to purchase additional Kingston 16GB SD cards and also an RPi 3 (as I was building one for a friend) to ascertain whether it was the RPi 2 or the card. I tried to insert the old SD card with the backup image into the RPi 3 but had no luck getting it to start so I decided to start from scratch and just reinstall OSMC (using the OSMC Windows installer) and selecting the newest 2 April build.

On 4 separate occassions in the last 24 hours (using 2 brand new Kingston SD cards) I have run into issues and have not gotten very far in the process. I am able to get through to the initial setup screen where language, region, name of device, connectivity and email settings are chosen, but it’s after that the issues start. On one occasion, I tried to install openvpn through remote SSH and apt-get. This seemingly looked fine and everything installed. Following a reboot of the system via the GUI power menu button, there were multiple errors and I was unable to get back into the ordinary GUI interface without error messages and a sad face. I put this down to maybe a bad install so started again by formatting the card and using the OSMC installer to download and write the image. The same thing happened on the second install (using a second new SD card). I decided to wait 24 hours, fully format my cards (using the erase function) and re-install using the OSMC installer. This time I didn’t install openvpn and just tried to reboot the system (after configuring my wireless connection) and manually restarting. I couldn’t get into the main OSMC GUI - different error messages and a sad face. I unplugged the power and turned it on - I saw messages saying the file system was corrupted and fsck was being run to recover. After 10 seconds it rebooted but I was never able to fully get into the OSMC GUI in the ordinary way. I powered off then hit escape to get into the command line / SSH. I generated a log and the report is set out here:

I haven’t run into install issues previously and can’t explain what is happening - whether it’s defective SD cards or whether the image hasn’t transferred over correctly. Any help on the above would be greatly appreciated before I give it another go. A working RPi with OSMC and VPN addons is a wonderful thing and I hope to be back up soon…!

As an aside, I tried installing the same 2 April build (fresh images following failed installs on the RPi 2) on my RPi 3 twice and ran into the same problems (both after seemingly successful installs of openvpn and then rebooting). I was never able to successfully get into the OSMC GUI in the ordinary manner following a reboot. I will try again this evening if helpful and can generate the logs if I run into issues.

PS - I don’t know whether this is a known issue but in the newest 2 April 2016 OSMC build and immediately following installation where one chooses the networking settings - the options are very unresponsive. It takes a while to enable the wireless networking on RPi 2 and connect to the network then exit. There is considerable lag and I didn’t encounter this before on earlier builds (nor was it an issue for the RPi 3 where the menus and functionality of the networking was fine). I thought I would mention this.

Kingston cards are problematic with the new Raspberry Pi SdHost driver.

Either change config.txt to dtoverlay=mmc immediately after first installation or purchase another SD card. Good ones are Samsung, SanDisk, or the official OSMC one.


Thanks for the prompt reply Sam. I will buy one of the cards you recommend and try again. Probably a reason they’re so cheap price wise…

The Raspberry Pi changes to the SD card driver are relatively new (the last few months). However Kingston SD cards in our testing seem to experience poor 4K random write/read speeds, which is independent of the SD card driver used, so can’t go wrong with getting something better if you want to use OSMC full-time.

I suspect compatibility issues will be ironed out very shortly by Raspberry Pi.