Multiple issues with 15.2 update:MyOsmc is not running and all video add ons are lagging and or not working

Hello,

The issue you are currently experiencing with OSMC:

  1. MyOSMC is not starting
  2. All video addons are either lagging or menu not appearing
  3. on soft reboot (via ssh) wifi connection is lost

What you were doing when this issue occurred

  1. It started shortly after I update 15.1 to 15.2

Whether you can replicate this issue on demand. If you can, then please provide some steps on how an OSMC developer can reproduce the same issue.

  1. Its always there now , I am unable to upload my log via MyOSMC but happy to send it via grab-logs(whats the exact format?)

----------Used OSMC pastebin , Shall I add to this thread?

The device you are currently running OSMC on

  1. RPI1

What peripherals are attached to the device?

  1. WD Elements
  2. WiFi Dongle

Has this issue been introduced by a new version of OSMC? When did the issue first appear and can you recall a time when it was not present?

  1. Yes , started with 15.2 and worked well prior.

Thanks,
Mar

Same thing here. Everything worked fine before but now it’s all broken.
Freezes and crashes in various video add-ons. Raspberry Pi 2 here.

https://osmc.tv/2015/10/osmcs-october-update-lands-with-kodi-15-2/
So things have been broken for 4 months? Because most users have been very happy with their 15.2 systems for the last 4 months.

You guys are going to have to provide some logs and a bit more details than “it’s all broken.”

grab-logs -A and then provide the URL
Before that if you are overclocking the RPi1 then disable that to check if it solves your problems.

Could you explain how “I updated” worked? Assuming that you have updated OSMC and that that pulled in a new version of Kodi. AS your update cycle is not clear could yo say if it was the october or november update or even an earlier.

Also as you had freeze problems earlier I really suggest that you check your SD card and power supply

Guys, no need to be defensive, OSMC is great so no need to attack users just because they complain on issues.

No one said “its all broken” and if you took 2 sec to read my initial post you can see I offered full logs and happy to help with QA

I went through the logs myself and found the culprit in the form of a misbehaving add-on who failed to parse URLs (bad regexp) but kept trying to connect to various sites.

My (overclocked) RPI could not deal with this overhead so everything was lagging including MyOSMC.

I have fixed the addon and will see if there are any issues, If there are I will post my logs.

Are you happy with the kodi.log or prefer the grab-logs data?

Thanks for looking into this.

Mar

It’s not about being defensive. It’s that your statement makes very little sense when you state 15.2 broke things for you after being the current release version for 3+ months.

Its makes a lot if sense as it describes the issue and perhaps a cause and as someone who support several software related products 3+ months is nothing.

I understand you are supporting a freeware but still your attitute should be more positive and helpful.
If you lack the patience to help you should focus on development instead. The OSMC/KODI community and your devs are very helpful anyway.

Thanks fzinken

here are my logs http://paste.osmc.io/axuduzuziz , I removed the overclocking but its still lags and wlan drops on reboot.

Tx
Mar

Seems you executed grab-logs -a instead of grab-logs -A

Could you detail a bit more what lags and how “lags” is defined.