Multiple problems since december update

Hello !
I have a Vero 4k and I’m experiencing a many difficulties since the December update.
My Vero is plugged to a Sony 40EX500 TV (which is not a recent model, but all worked fine 'till this update). It is plugged to HDMI 2. HDMI 1 is used for a Marantz NR1711 ampli.
Before the update : when I turned on the Vero, the display automatically switched to HDMI 2.
Now : the display shows HDMI 1.
So I have to switch manually to HDMI 2. But as the screensaver on Vero is active, when I use the remote, I switches again to HDMI 1.
If I pause a movie, wait a few seconds and use the remote, it also switches to HDMI 1.
Changing the HDMI port does not correct the problem.
Unplugging the Marantz ampli is useless.
Tried on another TV, same problem : display switches to another port.
Multiple reboots don’t correct the problem.
Worse, if a reboot and/or unplug the Vero from the TV, I lose the 1080p resolution and the only resolution possible is 720p. I have to unplug / reboot / plug again to get the optimal resolution back.
All of this looks like a nightmare, as I cannot see any method to correct these malfunctions.
Any idea to help ?

I have the NR1608 and recognise all these problems. I think you’ll need to unplug all your devices and let them wait a few minutes. Since I never had this problem before leaving the Vero switched on I bought an RF mains switch and now always power the vero down after using and then cut the power. These problems only reoccur when I foget to do that.

I second this advice. The TV is acting as the conductor of devices on the CEC bus. If it gets confused on where the Vero is plugged into, such as thinking it is attached through the AVR, then when a Vero sends out a signal to active it as a source, the TV switched to where it thinks it will be displayed. Unplugging the TV for a moment should clear out its CEC assignments and force it to poll for new fresh information.

With the new update I’ve got similar problem (but worse).
Resolution is locked at 720p.
I tried to unplug / reboot / plug again (as it worked before the update) but this time nothing changes.
I unplugged everything for 20 minutes, then plug… nothing changes.

Any idea ?

Try updating to the February update and post some logs in a new thread if you still have a problem

The February update is made since today, that’s the reason why I write again, as the problem is worse.

Sorry without a log I don’t have an idea

[    5.216910] hdmitx: hw: ddc timeout
[    5.237300] hdmitx: hw: ddc timeout
[    5.257615] hdmitx: hw: ddc timeout
[    5.278027] hdmitx: hw: ddc timeout
[    5.298353] hdmitx: hw: ddc timeout
[    5.318678] hdmitx: hw: ddc timeout
[    5.339004] hdmitx: hw: ddc timeout
[    5.359320] hdmitx: hw: ddc timeout

Vero is not getting an EDID from your TV. Try a different HDMI cable and/or try cleaning the HDMI plugs and sockets with contact cleaner.

I used three different cables, and tried another HDMI port. It doesn’t change anything.
I would like to point out that the problem has no longer been resolved since the last update. Before yesterday (before this update) I could correct it by unplugging / restarting / plugging in the Vero.

This doesn’t look like a software issue but a hardware issue as suggested above.

You can certainly install an older version of OSMC and see if the issue still persists.

I just restored OSMC from the 2023.08-1 disk image. After a 2nd reboot, the 1080p resolution is back…

If you update again, what happens?

There haven’t been significant changes to HDMITX infrastructure in recent updates that should cause this.

Can you post a log where resolution is detected and works normally before updating?