Multiple remote presses in 2015.07-1

Device: Vero
Installation media: SDcard
Connection: Wired
Power Supply Type: AS supplied with Vero
Power specs:
Peripherals: Logitech K400r keyboard / Harmony 650 remote
Storage Device: SMB
OSMC version: 2015.07-1
Audio/Video Output: HDMI

Logs: http://paste.osmc.io/buresavisa

Log is from starting kodi, pressing some buttons on the remote, and then using the keyboard to upload the log files.

Since upgrading today I am getting double button presses with my Logitech Harmony 650 remote, this has never happened before and I haven’t changed anything apart from upgrading. I will look into making a custom lirc file as I guess that will be the solution but wanted to flag this up as it seems something has changed that has broken what was working for my remote before…

You seem to have a lircd.conf file with dozens of different remotes in it - whilst this might have worked before this is not recommended, and will almost certainly be the cause of the duplicate button presses. (A similar problem exists with our rc6 profile)

What I would suggest is to run the following command from ssh:

irw /var/run/lirc/lircd-lirc0

Then press all the buttons for your remote to see what the remote “name” is, (this is the last word on the line that is the same for all button presses) then look through the file to find this particular remote name and copy and paste that section into a new file, then choose that new file in the remotes part of My OSMC.

Each remote section begins and ends with ‘begin remote’ and ‘end remote’.

That should solve your problem.

I removed everything from the MCE6 profile except for mceusb (which the command you suggested was reporting). This did not fix the double key presses.

I solved the problem by telling the Harmony remote to emulate an Xbox 360 remote and used the lirc profile for that.

Ahhh, I missed seeing that you had a Harmony remote.

I also have a Harmony remote (although a Harmony one, and I don’t use it with the Vero) and you’ll probably find the issue is that the profile for that remote is set to too many repeats - the default is 3 for most devices and that can cause unnecessary repeats.

It is possible to compensate for that by adjusting one of the values in the lircd.conf file (I don’t recall exactly what off the top of my head) but the better solution is to reduce the number of repeats for that device in the harmony software from 3 to 2, or possibly even to 1.

I had to do that for some of my devices in my AV system. It’s not easy to find the setting - I think you have to use the troubleshooting wizard and choose the option that says “my remote responds too often or not enough” or something similar to that, and you will find an option that lets you choose a value between about 0 and 5, with the default being 3. Usually dropping it to 2 is sufficient, and also makes the button presses a bit more responsive.

A bit too late now that you have it working using the xbox 360 profile (that is probably a good one to use if you don’t have an Xbox 360) but something to keep in mind for the future.

1 Like

Thanks for the tips, I’m going to stay with the Xbox 360 remote setup for now - this has an extra advantage that I don’t accidentally control my laptop with the remote when using it for OSMC (which was happening on the mceusb profile).

I’ve tried lirc0 and lirc1 and neither of these show anything on the screen after pressing a lot of buttons on the remote. Any other ideas of how to get my remote name?

I too am having multiple press issues and i can get them to go away by pressing the remote button really fast… so i’m sure it has to do with one of the .conf file settings (repeat, suppress_repeat, min_repeat, etc.). But first, i need to figure out which remote in that rc6 .conf file is mine, and hence i need the device name. I could guess that it’s the mce remote and just move on.

Ok, so i still don’t know what OSMC thinks my remote is called (the name as @DBMandrake calls it above). But, i did find this Gaplax: LIRC . Since i have an RHRC-11002, i tried some things:

  1. copied the “mceusb” section of rc6-mce-lircd.conf to a new file, mceusb_lircd.conf
  2. changed symbolic link lircd.conf to point to mceusb_lircd.conf
  3. rebooted
  4. still got multiple presses
  5. edited mceusb_librcd.conf and added “suppress_repeat 5”
  6. rebooted
  7. still got multiple presses
  8. copied the “mceusb_hauppauge” section of rc6-mce-lircd.conf to a new file, mceusb_hauppauge_lircd.conf
  9. changed symbolic link lircd.conf to point to mceusb_hauppauge_lircd.conf
  10. rebooted
  11. multiple presses are now gone

However, I’m still not getting the desired behavior in PVR / LiveTV, which is, the pause button doesn’t respond, and the jump back/forward buttons change the channel.

Does this mean i need to remap these “keys” with the gen.xml file in ~/.kodi/userdata/keymaps/ ?

Also, what is the default value for the lircd.conf link (that is, what file does it point to by default… after i changed it through the GUI, i’m not sure of what it was by default).

Edit - by the way, my pause, rewind, fast forward and skip back are working in Movies (library setup by adding a source in Video>Files and configuring the location as a source of Movies). However, my skip forward is not working.

Edit2 - I just realized that this is a thread under the Vero… I’m using an RPi2, but i think this still fits within the context of the post. Can we add RPi to the thread type?

Edit3 - I tried using irrecord to sniff remote button presses, but i couldn’t get it to work. If you’re really interested, i can turn on debugging and post a log file.