Music library empty, just shows "..", no way to add music

So I’ve replaced my old raspbmc/Rpi-B with OSMC/Rpi-B+. The TV show library works just fine, but I have had no success setting up my Music library.

After attempting to add my music to the library, the Music section is now empty and I can’t see any way to fix it. If I select the Music entry in the main menu, all I get is the two-periods parent directory item “…”. Selecting it does nothing.

The option to add content to my library is gone. I would like to remove all paths from the music library and start again from scratch, but I have been through all of the menus and can’t see any way to do that.

I’ve tried scanning the library for changes (no change), cleaning the library (no change), rebooting my Pi (no change), updating OSMC (no change).

Playing music files via File Manager works just fine, so this doesn’t smell like a permissions issue. Any suggestions?

I am a brand new OSMC user, but I cannot seem to get any of the libraries to work at all. Everything plays well from files manager. It may be that I just don’t know how to operate the media center but I tend to figure stuff out eventually.

There may be something wrong after all…

add a mouse click in music on files and you’re done:P

I too have been struggling with getting my CDs into the library and getting the artwork correct. Some things that I found out that I have to do to get things right.

  1. Pick the location where you want to keep your music and dont change it.
    Mine is on an external, USB connected, Passport, 1TB drive. In a folder named
    After much fumbling with tags and tag editors, I finally just rip the CD into its own folder and make sure that there is a .jpg file in the same folder that has the front cover picture. Name the picture as cover.jpg
  2. From another PC, I ssh into the raspberry (ssh osmc@, password = OSMC)
    and go to
    Be aware that .kodi is probably hidden.

Do a Linux command as ls -l - a
And you will see a bunch of files.
I was interested in any music databases and for me there was one

Apparently there can be more based upon some criteria I don’t understand.

Anyhow, delete these files and log out of ssh by doing an

Back to the Raspberry shut it down and start it up again and it will have a fresh clean library.
Go to the Music and you should have 2 sub menus.
Files and Addons.
Pick files.
In my case, my USB, Passport drive is listed as a music source. I think it appears automatically when it’s inserted.
Now I call up the context menu by pressing “c” on the wireless keyboard and one of the options is "Scan items to Library. I think a right mouse button will give you the same choices. Of course if you also have movies on there, they will also get scanned. So it is best to drill down to the Music folder. If you do that you will get more choices from the context menu.
Do it and you’re done.
I also like to clean the library afterwards.
Also, I recommend keeping each album in a separate folder.
I still struggle with multi disk and compilations though.

The scan is very fast so I never worry about doing it again. In fact if there was only one folder/album that I had changed, I would do only it.

Good luck


I am also having issues with the Music section. This may or may not be related to the original post but I am unable to scroll over to Files in the music section. I have attempted to add the library source manual but with no luck.

The display is actually different then the other categories. With the Video section, it shows Files at the top of my screen and I can scroll over and select it. Also, if I select Videos, it will also display a link there, Files, to then select a source. The Music section, on the other hand, shows the Files link at the bottom of the screen and I am unable to scroll over to click it. If I select Music, it doesn’t even show the Files link in those options.

I have also tried deleting the .db’s in .kodi/userdata/database location with no luck.

I am running OSMC on RasPi2 through HDMI through Sony TV. I control the menu system with my Sony remote control through the HDMI.

A side comment to theboy30: You have no business posting in forums. Forums have been put into place to help people that have questions about a product or service and are usually frustrated. Comments such as yours only frustrates users even more. Now obviously your comment was in jest but if you have no motivation to actually help people or lack the capacity to troubleshoot then do us all a favor and just don’t bother posting.

Any help would be much appreciated. Thank you to all in advance.


Did you click on the “…”? Have you tried switching the skin to confluence?

Thank you ActionA for a quick reply. The “…” doesn’t even appear… it is the strangest thing. I can’t imagine that the menus with be structured different in the code.

I have not even thought of trying a different skin. so THANK YOUUUU… I’m back to the good ol’ classic and there are my Music options!!!