Music library update crashes 4k

so, I attached an external USB drive (powered via an USB hub) and after the initial library scan it crashes every time I start a new attempt. Shows me the sad face. Other media on that drive can be scanned, it seems

Any recommendations?

Hi,

Please provide logs, showing the issue:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thanks Tom.

ok, will take me 24 hrs. I’m somewhere else but get back with the log

How are you powering the external drive?

How is it formatted?

Does accessing files on the drive cause a problem, or just scanning?

I got an USB-hub (powered via mains), the drive is FAT32 formatted. I can play what’s on the drive. I can scan new video files, it’s just the issue with audio library (it’s 80GB)

here’s a log, hopefully it’s all in it. http://paste.osmc.io/asitijotef.vhdl

Do you have FLAC files in your music library by any chance?

It has happened to me as well that some FLAC files have broken tags which cause Kodi to crash. If you look at those files with Mp3tag (Mp3tag - the universal Tag Editor (ID3v2, MP4, OGG, FLAC, ...)) you’d see that the column “Tag” doesn’t say “FLAC (FLAC)”, but something like “FLAC (ID3 v2)”. So, Kodi crashes when trying to add FLAC files that have MP3 ID3 tags instead of FLAC tags. Check on that in your library.

If this is the case, you may use Mp3tag to fix the problem: add the respective FLAC files to Mp3tag, highlight all of them, then press delete in Mp3tag, deleting all tags, and finally press undo which would rewrite the tags, but this time correctly as FLAC tags. The only thing that has to be done manually, is adding the cover art to the tags again. They’ll be lost during the delete und undo process.

there’re FLAC files indeed. I’ll try to apply your recipe. Thanks. I’ll report back here, will take some time though.

Just add all folders containing FLAC files to Mp3tag and sort by the “Tag” column… You’ll see right away whether there are any affected files.

It’s just an idea, but maybe it’s simple as that. This has happened to me before and after I had “cleaned” all my FLAC files from any wrong tag format, it worked like a charm.

You never scrap music files, in your log the kodi job stop when you scrap your movie foider
For your music files start scrap only for music (settings media file)
For music
basicly Kodi use Musicbrainz to scrap your music.
Backup you music folder before !
Try to check (and when you will update) your files before scrapping with Picard
Picard
I’ve more then 30.000 files in my music library, ogg, flac, mp etc and it’s works.
But when you have never use Picard before do it slowly.
When i did slowly, I mean artist after artist, when you have a folder organisation like
artist
– album
– album
Verify what you do before validation otherwise… you can restore your update
Michael
I
Michael
And also verify that you are up to date with your Kodi extensions

Please, read again the article @Tom_Doyle provided in post #2 and create useful log data as described. Your log data only contains the run of a videoinfoscanner while startup, nothing else.

Ok, seems the log is the wrong one. I could - as mentioned – read the library initially, and it has been annotated before with musicbrainz via QuodLibet

Kodi extensions are uptodate, just got 4k 2 weeks ago.

Also we need a “good” log

new, hopefully better, log is here: http://paste.osmc.tv/iwidomebet.vhdl

Looks like a bad tag.

18:32:28.626 T:3549426432   DEBUG: DoScan Scanning dir '/media/Seagate Expansion Drive/Seagate/Musik/Various Artists/The Essential Igor Stravinsky/' as not in the database
18:32:28.673 T:3549426432   DEBUG: unrecognized ID3 frame detected: PRIV
18:32:28.674 T:3549426432   DEBUG: unrecognized user text tag detected: TXXX:QuodLibet::albumartist
18:32:28.674 T:3549426432   DEBUG: Mis-match in song file albumartist tags: 1 mbid 0 name album: Works of Igor Stravinsky

Move the file somewhere else and see if the scan completes.

yeah, saw this one too. got rid of it, now it stalled at another file. At least I know know where to look. Thanks