My experience with OSMC RC2

Just to describe my experience with OSMC on R.Pi v1 today:

  • Downloaded and installed to card fine. Told it to manually configure networking. All installed ok. During configuration it couldn’t activate networking.
  • Reinstalled with automatic networking. All comes up fine. I have no idea how to access Kodi, define my media sources, etc. I ssh’d in, installed FTP, and tried to connect in like I did with Raspbmc. Couldn’t work it out.

Gave up, went back to Raspbmc. If there’s an install and user guide that could be highlighted on the download page that would be really helpful. Documentation is really important for new people, and I’ve been on the old system for what seems like years.

You are trying to do all this headless?

No, plugged into a TV, with a keyboard.

I initially configured networking in the windows installer. I may have entered something incorrect, I don’t think so, but once it loaded the wired network wouldn’t activated.

Once I did reinstall and get it working using DHCP I got to a home screen and had no idea what to do. I tried to set networking to a static IP but I couldn’t find where to set it. I went into the OSMC programs area which failed, but then a minute later popped up. In there I couldn’t set network anyway.

From there I wanted to start Kodi, but I had no idea. I wondered if I was meant to use that main interface to add my media sources on a NAS, but couldn’t work that out either.

So I gave up. Documentation is as important as software in many cases, especially if all that’s required is a few pages of getting started guide.

Everything you saw on the screen was Kodi + the OSMC skin + the MyOSMC settings addon. It would be very simple to scroll down to settings>appearance>skin and choose confluence and have exactly what you’ve always seen.

Also - very near to the top of our wiki https://osmc.tv/help/wiki

I couldn’t add media sources. I couldn’t connect to my MySQL repository.

I don’t need to use the old interface, I just need documentation on how to achieve things with the new interface.

Things the wiki needs:

  • How do I add my NAS/file share to OSMC?
  • How do I use a shared MySQL repository?
  • How do I configure network settings?
  • How do I ssh/ftp into OSMC?

http://kodi.wiki/view/Adding_video_sources

http://kodi.wiki/view/MySQL

Numerous forum posts demonstrate this… If you are having technical issues with the MyOSMC addon, logs would be invaluable for us to find out exactly what the issue is and prevent it from happening again. This wiki page gives simple instruction on using the log uploader that we’ve included for your convenience.

Again, from the wiki page https://osmc.tv/help/wiki/console

Reading it is equally important. But at the same time, we’re not gonna re-write the very detailed and current Kodi wiki. The only difference is the skin, hence the reason I suggested you swap back to confluence. After configuring in a familiar environment, you are like 6 clicks away from being back to the OSMC skin.

Great, thanks for the links. Making the information easier to find may be all that’s required, a quick “getting started” guide. For now though I’ve put my R.Pi back in place with the old software on it, I’ll look at this again once this program hits 1.0.

OSMC -

First problem: xbox remote not working

Found solution on the forum and tried to FTP into OSMC using filezilla. Directory listings are fine, but still getting errors writing a file to /etc/modprobe.d/

Tried to use file manager, but this is also giving errors. Gave up and used Yatse instead.

Next: Imported video library and OSMC crashed. 2 hours later, getting a bit hacked off now.

OSMC is not living up to my expectations.

Raspbmc for me :frowning:

Okay, Found a way to change the root password using PUTTY and the following comand - sudo passwd root. Then changed the file permissions of the folder i needed to create a config file in. Created file and remote now working.

Not exactly NOOB stuff but OSMC working well :smile:

Z

This is documented in our wiki

S