My new Vero 4K didn't last for a week

#1

Hi,

I’m having problems with my Vero 4K I received last week. I installed it without problems and played a few movies. Yesterday I tried to use it again but found the device completely frozen - it showed the main Kodi screen but did not respond to any input. So I powered it off and plugged it again but since then only red LED lights up and it doesn’t do anything else.

I’ve tried leaving it unplugged for a day but it didn’t help. So I installed OSMC on a flash drive using the windows installer and tried to reinstall it but it didn’t work. Even tried renaming kernel.img to recovery.img and starting it up while pressing the button using toothpick but all I get is red light and no video signal.

So is there anything else I can do or is my Vero dead? I don’t think I did anything unusual with it, the only thing I can think of is:

  • Installed few kodi plugins from Kodi CZ/SK repository for downloading movie info/subtitles and they worked fine
  • Lost power once due to a tripped breaker, but it booted afterwards without problem
#2

Might have caused some corruption.
Can you take a screenshot of the SD card you prepared so that we can see if you imaged it properly?

#3
 D:\>dir
 Volume in drive D has no label.
 Volume Serial Number is 60A0-1FD5

 Directory of D:\

16.03.2018  05:28            40 465 dtb.img
07.03.2018  12:53       155 259 964 filesystem.tar.xz
16.03.2018  05:28        22 036 480 recovery.img
               3 File(s)    177 336 909 bytes
               0 Dir(s)      73 527 808 bytes free

Here, I’m using Kingston DataTraveler Micro 3.1 32GB flash drive. I tried using some old 4GB micro sd card I found laying around but the installer got stuck on copying files so i assume its corrupted.

#4

Some ideas:

  • Make sure the Vero 4K is plugged directly in to the wall
  • Make sure only the remote controller is attached with HDMI and power
  • Try another USB stick.

Otherwise we would need to get the unit and PSU back and replace them for you.

Sam

#5

Hi Morgoth, did you solve your problem? I’m experiencing something similar, except I’m able to reinstall the OSMC and get the Vero back to life for another few days, until it freezes again exactly as you described…

#6

Well, yes. I sent it back, got a new one and it worked great since then. If you can’t ssh into it and restart won’t fix it I guess yours is also faulty and needs replacement.