My OSMC has failed


I’m not new to OSMC but very new to posting on this forum. Never had an issue with OSMC/Kodi that I couldn’t solve thanks to Google or this forum. I’m also a Belgian so sorry for my poor English. I’ll try to respect the best practices to post an issue.

My Specs:

  • Raspberry Pi 3b
  • OSMC (fresh installation)
  • KODI 18.2-RC1
  • Skin Estuary MOD V2 version 3.0.5

Everything started with the update of april. OSMC started to freeze and reboot when trying to update the library or setting a new skin… I had even empty settings menus. I decided to start from scratch on a new sd-card to avoid old addons issues. It helped for some hours till I decided to update the library and had the same issues freezings and reboots. And now I even have MyOSMC that crashes after kodi opens.
When I try to open it through the addons I have the following message:
“OSMC Settings Service failed to launch”

Except this issues I can watch my movies and shows without issues. But changing a skin or updating the library makes most of the time crash Kodi plus the fact that I can’t use MyOSMC.

Please could you help me?

You have run out of memory. I assume this is either something to do with an add-on (or add-ons) that you have installed or perhaps bacause of the Estuary Mod skin.

You can test if it a problem with your configuration by running the following commands:

systemctl stop mediacenter
mv .kodi kodi_backup
systemctl start mediacenter

Thanks for your response indeed now I can open OSMC again but how can I know which add-on was responsable of this issue?
The skin is recently updated so not really something that hasn’t the support of kodi community (I know OSMC community isn’t Kodi Community :wink:). Estuary is even a classic one.
Is there a way of tracking what is causing my issues?

Add one thing at a time until it breaks. Ideally it will be one bad add-on causing the problem, which is easiest to find, or a cumulative issue, which can be more difficult to resolve.

Hi dillthedog,

First thing first: thank you for your answer!
I tried what you proposed and installed only the skin Estuary Mod v2 (with the needed scripts except art beef) and it worked a day or 2 without having an issue but then after an update of the library it started again.

So I started to think that the issue was coming from my raspberry 3b and bought the Vero 4k. I installed the same scripts and skin and have no problems since a week! So I suppose that my pi has difficulties with the new Kodi and the skin.

Regards and thanks again!

I have no issue with the Vero 4k