My Vero 4K+ does not recognize my NAS' folders

Provide Debug logs otherwise we can only do guessing.
Also check your network with iperf3

I saw a Loging page but did not figure out yet how to use it.
After tweaking around managed to save it to:
https://paste.osmc.tv/uzeboxuyog

What parameters should I use?
The movies play perfectly on my PC, which is also connected to the NAS through the same network.
Also play fine on my TV.

Sorry I thought you had already the instructions for Debug logs. I added them at the end here for you to check (because the current logs are not debug enabled).

What I can see is Read - Error( -1, 103, Software caused connection abort ) which might come from the NAS but without Debug hard to say.

Check this thread, but I would first suggest to enable devugging und upload that logs.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

OK. Did two reboots and tried to play three movies. All had the same issue.

The Vero 4K is connected to the network with a cable. No wireless.
It’s connected directly to the switch the same way the PC, TV and the NAS.

Log file.
https://paste.osmc.tv/ukuduwuwig

I noticed you asked to use standard settings. So I changed to standard, enabled loging again, rebooted twice again, and tried to play three movies.

Same result. Here’s the new URL: https://paste.osmc.tv/qozojeroki

I’ll see how to use the network bandwidth utility, but I don;t think it’s it, since both the TV and the PC work fine. The TV is even at the end of a long cable.

The Vero and the PC are right beside the switch, since I am still configuring the Vero.

In settings>services>SMB client> there is an option for mitigate MTU issues (or similar, don’t have it in front of me at the moment) can you try enabling that, reboot, and see if that fixes the playing issue. I thought you said you had switched over to nfs?

Not yet. I tried a couple more settings in the NAS but no luck yet.

So, I decided to create the library using the SMB connection and test it.

This did the trick. It’s working now. Thanks!

Now back to figure out the NFS issue.
Besides authorizing the Vero IP in the NAS, I also created an account for it, which I am using for the SMB and specifically authorized it to read all the folders under that parent folder Captured_Movies.

Still no luck.

I think this means that your NAS is probably set to only allow up to SMBv2. If you can find the setting in your NAS to enable SMBv3 and possibly set Kodi to use min/max SMBv3 (this might not be necessary) you should be able to disable that MTU option as it does come with a speed penalty. Of course if you get NFS working the point is moot.

You are correct. It was set to Max SMB 2. I changed to Max SMB 3.
It also has a setting for “SMB 2 and Large MTU”

Which of the two is better.

Question about the iperf3. The documentation says that I should install it in both devices that I can to measure the network speed. However, I do nto know what the Synology DSM is based on. Probably soem Linux distro, but the iper3 website has several.

Do you know which? Synology has an app store where I can download apps and install directly there but it does nto have iperf3 there.

By the way. While I was tinkering with the NFS, I saw an option to use Kerberos that I also saw in the Vero.

Right now, NFS is set to use “sys” as the security.
The Kerberos has three options:
authentication
integrity
privacy

Could it be related to the Vero being able to connect but not see the folder’s contents?

I would not enable large MTU to avoid any incompatibilities. As for iperf i’m sure googling a guide specific to Synology should turn up something.

Hi! I hope you have been having a great Christmas time!

I hooked up my Vero 4K+ to my TV and it’s working great. I’m still using SMB because I faced a few problems getting Kodi to properly recognize my movies and TV shows library.

Went to the Kodi forums and orver there found out that the latest Kodi version has a bug that requires us to use one of the online databases when scanning our library. Cannot use the “internal sources only” option. And then Kodi’s database settings must math the one we used when organizing everything with TinyMediaManager.

So, I have been spending all my time renaming and reorganizing my movies library to match Kodi’s requirements, which are a bit picky.

Regarding that, I would appreciate your advice regarding a good Kodi UI for what I would like to setup. I tried the OSMC UI, Kodi’s own and a couple more, and so far Kodi has been the one that got closer. I am posting in this thread, but can open another one, since this is more related to Kodi’s UI configuration.

Here’s what I am looking for.

  1. I want to configure the movie’s genres that I want and remove the ones I will not use.

  2. Kodi pulled a ton of tags from the online databases. How to delete them all and only have the ones I want?

I also have a third question, about the Vero 4K+ itself.
3) When I turn the Vero 4K+ off using the UI’s power button, the only way to turn it back on is by unplugging the power cord and plugging it again. Is there a better way? I would rather not letting it on when not using it.

Thanks much!

Use the supend mode it throttle the CPU and power consumption is minimal.

You have a source for this as I hadn’t heard of this previously and I just did a quick test and it seemed to work just fine. I made a new local profile on my PC and added a source that contained 748 movies that have local information that was generated by TMM and set the scraper to “internal sources only”. It successfully (and correctly) scraped 747 movies. I then checked the one movie that did not come in and it was missing the nfo. I opened TMM, went to that movie, and told it to rewrite the nfo. Updated the library in Kodi and now it picked up all 748.

Your using TMM to organize so you would do it there. If you double click on a movie and in the window that comes up click on the “details 2” tab you will see the option to add and remove both. If you had set your Vero up in the preferences you could then right click on the movie you just edited the tag on and select Kodi 18>reload selected items in Kodi library and your changes will be instantly picked up saving you the hassle of refreshing in Kodi itself (note that nfo changes are only picked up on new media item scans and when you manually force a refresh, never with a normal library update).

If you search around there are some people who do this with smart plugs and other means but it is prone to causing corruption in the OS unless one is exceedingly vigilant about always shutting down before power is cut. IMO it is not worth the headache for the minimal power savings.

Here it is. It’s in the thread I opened because I could not get Kodi to recognize the episodes in TV Shows and some Movies. It appears that it started with a new version of Kodi. Which version are you using?
After I followed the recommended procedure, it worked.

Whole thread is here.
https://forum.kodi.tv/showthread.php?tid=359260&pid=2998056%20-%20pid2998056

I noticed that the new genres and tags I created appeared in Kodi. However, the ones already there do not seem to be removed. I started reading about editing library nodes but do not want to try it yet, since I may break things up.

For example, I do not want the “Thriller”, “Horror”, “Romance” genres to appear in the menu. How to remove them?

As for the tags, there are too many. I have been wiping them out in TMM and adding only the ones I want to use. However, it seems that the ones already imported by Kodi are not being erased.

If I can get this done, it will help me browsing and finding the movies I want faster and not having to use the search feature or browsing through many movies.

Of course, I am open to ideas to make navigating easier when we have a big library. I’m still new and can use the experience of who has been using Kodi longer than me. :slight_smile:

I noticed that the context menu allows for removing some main menu items, such as TV, Games, etc. Is it safe to wipe them out?

Thanks much!

Delete the source, let it clean the library and re-add the source should remove the errant genres.

Kodi doesn’t require an online db. I’ve got a tv show in my library that doesn’t appear online anywhere. Iirc the episodeguide tags can cause an issue if left in the nfo. If it helps this is the nfo:

(There is a bug in that Kodi on initial scan will ignore the local actor thumbnails, but a refresh picks them up.)

What version of Kodi are you using? According to them, this issue appeared in a new version.

Here’s my repro steps:

  1. copy folder in the TV Series folder in the NAS
  2. review and rename episode files following Kodi’s manual instructions
  3. run TMM, refresh source, new TV series appear
  4. run "search and scrape selected TV show(s) on TMM
  5. double-click new TV series and make changes I want (e.g. remove unwanted genres, add the ones I want, same with tags, add/edit artwork, etc.), and save
  6. run Kodi on Vero 4K+
  7. go to Settings>Media>Videos>TV Series source> run “update library”

At this point, if Kodi is pointing to “Internal Sources” some TV series would come with no episodes, only the cover art and general info about the series. Same for some movies.

Once I started pointing Kodi to the same database used in TMM, it started populating all TV series and movies correctly. Only problem here is that it also pulls a ton of tags and I have to delete them in TMM later.

How can I remove all tags from Kodi in bulk? Is there a way to do a SSH to the Vero 4K+ from my PC, access the tags’ database and wipe it out?

Thanks!

Cheers I was not aware of that one but I understand it now and see why I had not run across it yet myself. Karellen’s responses there were nuanced so it may be worth reading again if there was something you didn’t fully get.

As for the tags they are part of the media information and Kodi just does a lookup. As long as you have any media items with a particular tag then that tag will show up when Kodi does a search. If you want bulk editing you would need to look at what is available in TMM or ask on their forum. This is not a topic I’ve personally ever looked into. Off the top of my head I think what you probably need to do is in TMM settings remote tags from your scrape settings and then update the scrape and Kodi if you didn’t want to blow every tag away and only add your own. To me this seems like more effort than going one by one in TMM and removing what you don’t want (ie typing in new tags is more effort than clicking on juw5 existing unwanted tags and pressing the delete button).

It appears that you may have some confusion on library updates and these nfo files. When you do a library update Kodi only ever looks for new files. If you want to update an existing library entry to pick up an updated nfo then you have to either bring up the info windows in Kodi and click refresh, delete it from Kodi so it gets picked up on the next update, or via TMM with the method I outlined earlier.

You would have to edit Kodi database itself and i’m pretty sure nobody’s going to walk you through that. That would also be a bit pointless as your editing with TMM so your edits need to be done there and then Kodi updated to reflect those changes. If you don’t want tags, or genres, or whatever to be scraped in TMM you need to uncheck those options in TMM. If you want items already scraped in TMM to reflect these updated scrape settings you have to rescrape in them in TMM.

The only thing I wasn’t seeing how to do with a quick browse it exclude the <episodeguide> from being written but there may be a way. That would be a question for the TMM forum probably.

18.9. In the nfo I posted the <episodeguide> is empty, so Kodi doesn’t go looking for a guide which can cause a problem.

(I use Media Companion on Windows which is similar to TMM. It’s a bit simpler, eg it doesn’t include library tags by default, only genres, and for tv shows only uses the TVDB at present. It has an option not to include <episodeguide>. That line is unnecessary if you have episode nfos, and may cause trouble if future you rebuild your library on Kodi and the linked address is outdated.)

However for the moment it shouldn’t matter, even with the TVDB/TMDB scraper selected Kodi will only pick up genres, tags etc that are either in the nfo, or are linked to in the nfo. You shouldn’t have to delete them later in TMM: all the editing is done there first. To give you something to compare with, for your Mysterious World show this will work if you have episode nfos. I’ve added some genres and actor thumbnails. nfo

Same goes for movies, there’s no need for the TMDB scraper. Eg you can make nfos for your home movies and Kodi will put them in the library.