My Vero 4K+ does not recognize my NAS' folders

I just received my Vero 4K and managed to set it up in my home network and it can connect to the Internet. I am using wired connections, no Wi-Fi.

My first step was updating the software, which worked fine. The System Info page shows it’s running Kodi 18.9

Following that, I tried to connect it to my Synology NAS following the steps in the Wiki page.

In the NAS, I enabled the file sharing as NFS as recommended, with the following settings:
Hostname or IP: my Vero 4K’s IP address in the network
Privilege: Read/Write
Squash: No mapping (also tried other settings without results)
Security: sys Enable asynchronous: yes
Allow ports higher than 1024: no (also tried yes, with no results)
Allow users to access mounted subfolders: yes

In the Vero 4K I went to Videos > Add videos > Add files
On the page I tried two methods:

  1. Browse - clicking on Browse opens another page where I chose Network File System (NFS)
    It opened another page that showed my NAS’ IP address.
    I clicked there but it does not see any of the folders.

I saved it anyway and it opened another windows asking how I wanted to scan for the files. I left the default options. After I click OK it simply did not seem to be doing anything.

I then tried to force by typing the patch as instructed in the Wiki page: nfs://SERVER/path

I typed the path in two different ways:
a) typing the server name/folder1/folder2
b) typing the IP address/folder1/folder2

It looked like nfs://server name/folder1/folder2

It then opens an error message saying that it “could not retrieve directory information”.

As a test, I connected a USB hard drive and added it using the “Auto-mounted drives” option and everything worked fine. So, it appears that the issue is in the Network settings. I have a couple questions:

  1. any different settings to try in the Vero 4K? - I also tried turning SMB on in the Vero 4K, but did not make a difference

  2. how to delete or edit the file paths in the Video list? - I see the options to Browse, Add and Remove. However, cannot click on the Remove option. My Video Files is looking like a mess because I added a few paths trying to get connected but all go nowhere.

Would you please advise?
Thanks!

Videos - Files, when you are on one of the sources click the context menu button (3 lines on the vero remote) then menu on left pops up you can choose remove.

If there are problems with adding a NFS source I always suggest first to check via the Command Line if the server reports correctly.

See below how to access command line and then run showmount --exports <IP of Server>

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

When I type this commend line with the NAS’ IP address I get the path I am sharing (using NFS) and my Vero 4K’s IP address in the network.

Something like this:

Export list for
<path> <Vero 4K's IP address>

Should I see anything else?

Thanks much for your help!

Fixing the message I get.

Weird, for some reason it keeps “eating” part of the message I type.

Trying again:

Export list for [ NAS IP address ]
[ path shared in the NAS’s NFS settings ] [ Vero 4K’s IP address ]

I fixed you message. Use the </> button from the top to format messages that include any characters that falls into HTML formats.

To be honest no need to hide such information. It will not harm if we know your LAN IP addressing but it surely help for troubleshooting together if we know it.

Anyway so if you enter it in Kodi with nfs://<Vero 4K's IP address>/<path> it is not working?
What is the NFS version configured on the NAS?

One more details, not sure if it makes a difference.

The video files are organized in a folder structure that looks like this:

Root/Movie Type/Movie Title

Movie type is: Action, Sci Fi, etc.
Movie Title is the Movie Title and contains the movie file, artwork, SRT files, etc.

However, I selected the NAS to share all subfolders.

In Kodi I enter the NAS IP address.

NAS is 192.168.0.7

So, I start browsing and search in the NFS when adding file.

In NFS it shows my NAS’ IP address. I then add the path: /Volume1/Movies/

Movies is the root folder and all other folders are located there.

My Vero’s IP is 192.168.0.22
Is it the IP I should input when pointing to the movies server?

I checked the Synology’s software but did not find any version for the NFS.

However, there’s an option to enable NFSv4.1 support. But it asks for a domain. Therefore, I did not enable it.

In the advanced section it has the box “Apply default UNIX permissions” checked.

You would enter nfs://192.168.0.7/Volume1/Movies/ if /Volume1/Movies/ is what is shown in the output of the showmount command.

Correct. That’s how it looks like when I finish setting it up.
nfs://192.168.0.7/Volume1/Movies/

It appears to recognize that location and after I accept it, it pops up a scan dialogue asking whether I want to use the movie database, is movie files are in their own folders, etc. I just change it to only use local info and click OK.

It says it may take some time, to index, but it’s just a blink (I have over 1000 files there, so it should take longer)

When it’s done I click on the “Movies NAS” location that I just created but it comes up empty.

I right click on it ans tel it to scan for new content. Still nothing.

I also copied one movie to the root folder to see it if it would find it there, but also does not see it.

So do you have proper NFO files for each of the movies? Otherwise you would need to use the online scrapers

I did not know that.

I just right clicked and opted to use The Movie Database and restarted the process.
In settings I opted to keep original title, disabled Fanart and trailers.

Turned on the option “movies are in separate folders that match movie title” and “scan recursively”.

Still no changes.

Shouldn’t it be able to at least see the files and play them?

I ran a test using a USB drive connected directly to the Vero 4K and it worked perfectly. It could see all files and play them. Just did not have the movies’ info.

Yes it should if you go via Videos - Files - <Source>

When I navigate there via Videos > Files > Movies NAS (location name I gave to it), I only see the two dots that bring me back to the parent folder. Nothing else.

What I find strange is that it does not even see the movie file I put directly in the root folder.

That is strange, something must be not right in the config.
Let’s check the sources.xml file, in CLI do paste-log .kodi/userdata/sources.xml and share the URL

https://paste.osmc.tv/afazewaxic

This one has no share mentioned

<source>
    <name>Movies_NAS</name>
    <path pathversion="1">nfs://192.168.0.7/</path>
    <allowsharing>true</allowsharing>
</source>

This one may choke on the space in the folder name

<source>
    <name>Movies</name>
    <path pathversion="1">nfs://192.168.0.7/volume1/Captured Movies/</path>
    <allowsharing>true</allowsharing>
</source>

Also earlier you wrote “Volume1” with capital V. Suggest you post the output of showmount so that we can advice.