My Vero 4K+ does not recognize my NAS' folders

So, just for fun, I tried to use a different protocol and chose the UPnP devices option.

In “Browse” I picked UPnP and it saw my Synology NAS. However, for some reason it did not let me pick it.

When I click OK, the configuration dialogue box only shows upnp://
No path or any other info.

I then picked SMB and configured following the instructions in that Wiki page
https://osmc.tv/wiki/general/file-sharing-with-a-nas,-media-server,-windows-share-or-other-device/

It appears to be working. Now I see an indexing going on on the top right corner.

So, it appers to be something with the NFS and UPnP configurations.

UPNP is a protocol with the intention of making services ‘discoverable’. NFS/SMB are a bit different in that regard, with the latter formerly implementing it only to remoe it due to security reasons

I ran the showmount again and got this.

/volume1/Captured Movies 192.168.0.22

So, I should not have spaces in the folder names?

Using SMB, it’s still indexing.

I checked the NFS path and it looks like this:

nfs://192.168.0.7/volume1/Captured Movies/

No capital V. It matches the showmount.

Well then go with that one first

Generally I would suggest to avoid spaces as you otherwise have to mask them e.g. with Captured\ Movies

This one has no share mentioned

Movies_NAS
nfs://192.168.0.7/
true

  1. How would it look like if the sharing part was working properly?

It’s still indexing the files. I’ll leave it finishing the stuff and tomorrow I’ll replace that space by an underscore. Hopefully it will not break a lot of stuff.

I read that NFS is preferred over SMB because of performance and reliability. Furthermore, there’s that part of me who wants to get the stuff working properly. :wink:

So, tomorrow morning I’ll replace the space by the underscore and will try the NFS again.

  1. About the library database, probably will have to reindex everything again, correct? That will break the path that it’s creating for the SMB stuff.

I saw that it did not catalogue some movies the right way anyway.

A third question: Is there a way to get all episodes of a series to show together? I saw an option to get all files under the same folder placed together, or something like that and enabled it. However, I can already see many episodes arranges as movies. Any tricks for that?

Thanks much for your help and patience!

Cheers!

Yes if you swtich to NFS you need to reindex (you could use path substitution but as you are at the start of your journey I suggest reindex.

If you remove the space you will break everything you already scraped. At least with SMB it is totally fine and I’ve never had an issue with it (I have sources with spaces myself). I don’t know if NFS is the same (never used it).

As for the TV shows please refer to the following articles which should answer most if not all of your questions. Basically if you have TV shows showing up as movies that means you have them located in a path set to scraping movies. The TV show files and movie files must be in two different folders that are NOT nested one inside of the other.

https://kodi.wiki/view/Adding_video_sources

https://kodi.wiki/view/Naming_video_files/TV_shows

It just finished indexing. Lots of errors.

As I am browsing, through the files, it started getting slower and slower, and finally gave me an error message saying that software caused the connection to abort.

Is there a tutorial teaching how to set the library, the fields we want and the values to fill there?
The way it automatically indexed using the online database made a mess out of how I had organized the movies. Let alone that there are many movies with the wrong poster and some even came up with a totally incorrect description, actors, etc.

I’d rather create my own database and fill it manually.

Thanks!

If you remove the space you will break everything you already scraped. At least with SMB it is totally fine and I’ve never had an issue with it (I have sources with spaces myself). I don’t know if NFS is the same (never used it).

I think it also broke for the SMB because when I clicked in some files it said the movies were no longer available.

As for the TV shows please refer to the following articles which should answer most if not all of your questions. Basically if you have TV shows showing up as movies that means you have them located in a path set to scraping movies. The TV show files and movie files must be in two different folders that are NOT nested one inside of the other.
Thanks! I’ll take a look at them.

The space did not do that. It sounds like you have issues with your network you need to track down. There will be some initial slowness when you first browse any given section of a library as the box is busy caching artwork. This is normal and expected behavior. If you have your files named in an acceptable manor and your shares are setup correctly you should find that Kodi will correctly scrape almost all of your content with artwork without intervention. There are outliers where you may have to tweak to get a show to scrape correctly but these are outliers.

You can’t make the database manually but you can generate nfo files and tweak their content with a media manager such as tinyMediaManager and this will override the online scraper. This is not needed for most commercial content though.

I cleaned up the library and fixed the path in the Vero and the NAS.

In Kodi it now looks like this: nfs://192.168.0.7/volume1/Captured_Movies/

Showmount now shows this:

Export list for 192.168.0.7:
/volume1/Captured_Movies 192.168.0.22

I also checked the sharing. It looks the same. How should it look like?

osmc@OSMC:~$ paste-log .kodi/userdata/sources.xml
https://paste.osmc.tv/adoyayiyuc

Auto-mounted drives /media/ true Movies_NAS nfs://192.168.0.7/ true
indent preformatted text by 4 spaces
<sources>
<programs>
    <default pathversion="1"></default>
</programs>
<video>
    <default pathversion="1"></default>
    <source>
        <name>Auto-mounted drives</name>
        <path pathversion="1">/media/</path>
        <allowsharing>true</allowsharing>
    </source>
    <source>
        <name>Videos SMB</name>
        <path pathversion="1">smb://192.168.0.7/video</path>
        <allowsharing>true</allowsharing>
    </source>
    <source>
        <name>Movies</name>
        <path pathversion="1">nfs://192.168.0.7/volume1/Captured_Movies/</path>
        <allowsharing>true</allowsharing>
    </source>
</video>
<music>
    <default pathversion="1"></default>
    <source>
        <name>Auto-mounted drives</name>
        <path pathversion="1">/media/</path>
        <allowsharing>true</allowsharing>
    </source>
</music>
<pictures>
    <default pathversion="1"></default>
</pictures>
<files>
    <default pathversion="1"></default>
    <source>
        <name>Movies_NAS</name>
        <path pathversion="1">nfs://192.168.0.7/</path>
        <allowsharing>true</allowsharing>
    </source>
</files>
<games>
    <default pathversion="1"></default>
</games>

You need separate sources for movies and TV shows so you need to either something like this

nfs://192.168.0.7/volume1/Captured_Movies/Movies/
nfs://192.168.0.7/volume1/Captured_Movies/TV/

or add a share on your server and have something like this

nfs://192.168.0.7/volume1/Captured_Movies/
nfs://192.168.0.7/volume1/TV/

Each source gets set as what kind of media is on it and a scraper is set for that type of media. Even though the default scraper for movies and TV is TMDB the actual scraper that is used for each type is not the same.

You can’t make the database manually but you can generate nfo files and tweak their content with a media manager such as tinyMediaManager and this will override the online scraper. This is not needed for most commercial content though.

Thanks! Thank is working so far. I deleted the library automatically created by Kodi and scanned again using only the internal option. At least it kept the folder structure I was using originally, which I like better than the arrangement made by the automatic scan.

I used the tinyMediaManager in a few movies and it seems to work and ran another scan using only internal sources and it worked fine. I see there’s a $10 charge for the full software but it’s worth it.

This problem is solved. Now back to the networking issue. I’ll run more tests and post here what I find.

Cheers!

I see that you are quoting peoples post to have the context which is good but seems you haven’t seen the quoting function of the forum.

Just mark the text you want to quote with the mouse and a "Quote button should pop up next to it. Just click that and the text will be added to your post with the respective quote relation (as in the top of this post).

1 Like

Go it. Cheers!

Sorry, I guess I need to start adding a warning now when suggesting this software. You don’t actually need to pay for version 3 of the software as it is shareware. Version 4 of TMM is a paid program but at present there is not a large disparity in features. Version 3 is still available to download from their website.

1 Like

No worries. I am having a new problem.
I used the tinyMediaManager to create several nfo files and thumbnails and saw that it saved each in each movie’s folder. So far so good.

I then ran the library update using only the local source and Kodi created the library with all the data.

After that I decided to run a movie to see how it was doing. Now Kodi does not play any movie. Tehre’s a spinning dual-circle thing in the middle of the screen and appears to be in an eternal loop. I tried other movies but got a similar result, such it started playing and immediately stopped.

Is there any setting I need to check there?

Still using the SMB.

Provide Debug logs otherwise we can only do guessing.
Also check your network with iperf3