My Vero 4k has crashed after update today

I have the sad face blue screen recycling. Tried powering off and same result.
I see others have had same problem but please note I have no done anything special to repos. I have been using the updates when notified and from standard repos whatever they are.

I am able to ssh into the device and can probably get a copy of the log but which I do not know. What is directory/log I need?


I responded to your other post.

Are you sure?

Please run grab-logs -A and send the URL

Hi Sam,
Sorry to be dumb as usual but here is what I have:-

osmc@osmc:~$ run grab-logs -A
-bash: run: command not found

Just type ‘grab-logs -A’, not ‘run’


Dispatching logs ...
Logs successfully uploaded.
Logs available at

Hope this helps and many thanks.

As suspected, your problem is caused by:

deb bullseye-devel main

You have at some point enabled a testing repository which is experimental.
Leave that line in for now, and I will release a fix to this repository later. Then I suggest you remove it from /etc/apt/sources.list

1 Like

Hi Sam, many thanks and will do as you suggest but AFAIK I have not enabled any testing repo!

You enabled the testing repository some time ago it seems. This isn’t something that would ever be done automatically.

You should now be able to update as follows:

sudo apt-get update
sudo apt-get dist-upgrade

And the issue should now be solved.

I suggest editing /etc/apt/sources.list and removing the ‘buster-devel’ line to avoid any unexpected updates.

1 Like

I have the same issue as @Budgie. I have not access to device right now but I’m wondering: for me, veo 4k reboots to sad face continuously. How do I write those commands?

Instructions for connecting to the terminal can be found in the following page…

You should follow @darwindesign’s advice but also remove that testing repository.

Hi Sam ,
Think normal service restored, for which many thanks.
You suggested I removed the buster-devel line. I do not have this now, what I have is:-

osmc@osmc:/etc/apt$ cat sources.list
deb bullseye main contrib non-free

deb bullseye-updates main contrib non-free

deb bullseye-security main contrib non-free

deb bullseye-devel main


Which should I delete?

That clearly shows the bullseye-devel line at the bottom, if you don’t want any pre-release version and you want a stable system, take that one out too.

Sam by mistake wrote Buster

I was wondering because I thought that I couldn’t enter ssh if it was showing blue smile. Now it’s solved and bullseye-devel line is erased. Thanks!

Hey I have been having an issue with Vero 4 as well. Anytime I press a key on the remote the screen goes blank for a few seconds (but it does execute the command). Eventually it will just crash and reboot.

I don’t think this issue is related.

Issues have been fixed for other posters and the issue was they had the staging repository activated. You do not seem to have this activated.

Your log does not show Kodi crashing.

I’d suggest a new post so we can get this solved promptly

Do you have an opportunity to reinstall OSMC?



I was hoping to avoid a reinstall.

Ill start a new thread tomorrow and ill let it crash before i do a log again

It’s incredibly odd Sam. It has been playing up for WEEKS but today it’s all behaving normally again. I see some addons were updated. Maybe that fixed it!