My Vero 4K has packed up, any help appreciated

So I came home today and my Vero was going through what seemed an endless bootloop,
it was fine last night the last time I used it.
I haven’t powered it down since, just left it as I always do as always on.
I am now getting the red light briefly flash then some writing on the screen which is too quick to read followed by the OSMC splash screen then please stand by only for this to keep repeating.
Is there anything I can do to recover it or is it now an ex Vero 4K?

Have you tried re-installing OSMC?

Did you have a power cut recently? This might have corrupted the internal storage. The good news is that you should be able to fix this easily.

See Reinstalling OSMC - Vero 4K - OSMC


Thanks for the quick reply but it doesn’t seem to have worked.
I don’t have any spare sd cards so used a USB stick, I inserted it with the power off then powered on, after a while of things happening I now just get a blue screen with a sad face, any other suggestions?

  1. Can you still access it by SSH?
  2. Did you used the Kodi 18 version that is under testing?

I can’t access via ssh anymore and I used the latest 17.6 build which was June.
Most of the writing that comes up appears to quickly but the last thing I was something about strting smpt then smpt failing

I’m going to order an sd card from Amazon Now and try that later.

Also give the SD card a screenshot after imaging so we can make sure you’ve set it up properly.


I’m getting somewhere in diagnosing this, I downloaded an image and then set up the USB stick from that image via the osmc installer, I disconnected the network cable from the Vero and then I then put the USB stick in the Vero and powered it up, it formatted then installed OSMC (which hadn’t happened before),
I went through all the setup procedures until it got to setting up the network, as soon as I chose the manually setup a network option the bootloop started again, I guess from this my Vero is fubared in which case I need to find out how to return it, or the psu is fubared and not supplying enough power for when everything is working.

Hmmmm Amazon excelled themselves and I have the sd card already but its kind of a moot point, my Vero will now not boot at all, I just get the red light when powering on no matter what I have connected, the sd card, the USB stick, or nothing at all, I just get a red light with no action whatsoever from my Vero 4K :frowning:

@sam_nazarko how do I return this and get a replacement?

How did you get an SD card that quickly!?

Can you show me a screenshot of the contents of the SD card so I can see if the installer has been loaded correctly?

BTW: it’s very hot in Blighty at the moment. Make sure the device is in an open area and not in a cupboard.


Hi Sam,
I used Amazon Now, I must admit even using that service I was surprised to get the card that quickly.
I have to be up for work in 8 hours so if its ok I’ll send you a screenshot tomorrow when I get home but as I said I think its a moot point as my Vero now wont even power up.
oh and my Vero is located on an open top shelf.

Please let me know your order # and confirm if the address is the same and I’ll send you a new PSU. I’d be surprised if the Vero 4K itself is faulty.

Order #13289 (December 6, 2017)

Please can you use the shipping address that was in that order as there will be someone there all the time to receive it?

I appreciate you are very busy at the moment but could I ask @sam_nazarko what timescale I can expect the new PSU to be dispatched please?
I just want to know so I can decide whether to set up an alternative to watch my library or wait for the new PSU to turn up.

You will have the PSU by Wednesday morning latest

Wow that’s great service, thanks for the confirmation.
Fingers crossed it is just the PSU faulty as it sounds like you don’t have any 4K’s left if the main unit has gone down.

We will still be making this model until June 2019 and we have plenty of spare parts and a surplus of replacement devices for warranty requests.


Phew, after the time I’ve invested to perfect it with my setup I’m quite fond of my 4K, good to know if its a worst case scenario I can get it replaced :slight_smile:

A quick thanks to @sam_nazarko
I received my new PSU today and whilst I haven’t set up my Vero 4K properly yet all appears to be good with it again :slight_smile:

Your customer service is the best I have experienced in many a year and I sincerely hope you sell many Vero units over the years and make the money your efforts deserve.

P.S. Do you need my old PSU back to claim on it or shall I drop it off at the dump next time I’m passing?

1 Like

Hi Mike

Glad to hear that this is now working properly.

Apologies for the slightly late delivery. Royal Mail have moved us over to a new system (not at the best time); and after a lot of swearing we have finally got to grips with it.

We do not need the old PSU back; you can just recycle it.

Because the power supply was not stable when you tried to use the device I’d recommend another reinstallation to be on the safe side. You’ll need to re-image the card for this.

Thanks for your kind words.



I have discovered an unexpected bonus whilst re-setting up my Vero,
I followed Sam’s advice with the new PSU and reimaged the card then reinstalled OSMC.
Due to time shortcomings so far I have only set it up with my ripped 4K HDR movies but I now find all of those which have DTS variant soundtracks now work perfectly with my amp without me having to turn off DTS-HD in Kodi’s system settings, this was not the case before my Vero/PSU went wrong.

I used the 2018.06-1 image for my card, I’m pretty sure my Vero had updated to June’s download before it went wrong, so could it be those having difficulties with the HD variants of DTS might have a dodgy PSU or did my Vero just not update to that release when I thought it had and June’s release has fixed the DTS problems?

I don’t think the PSU would’ve impacted passthrough. It’s possible audio wasn’t configured properly on your device before