MyOSMC update fails with Add-on error

Tried to upload logs but get a warning exceeding size.

Any thoughts?

Try a dist upgrade via the command line.


Thanks Sam

How is this performed?


sudo apt-get update
sudo apt-get dist-upgrade

Brilliant, seemed to have worked.

Tried MyOSMC manual update (just to see) and receive ‘Insufficient space for Update to proceed…’. Howver I’m running a 8GB SD card and Kodi reports only 30% is used.

Sorry, I’m not good at the Linux stuff!

On which partition? Your /boot is probably full. sudo apt-get autoremove will get you some space page.


Ran the autoremove command several times. Can I read the SD card with Windows and tidy somehow?

No, Windows would only see the small (250M) boot partition. The root partition can only be mounted on a Linux or MAC.

That means it is not old kernels taking up free space. We still don’t know which partition is full, it would be good to know.


Thanks for your help Sam.

According to Kodi…

/dev/root 4.6G available
/dev/mmcblk0p1 15M available /boot

Does this help?
15M isn’t a lot no matter what!

OK, so now what exactly are the contents of /boot?

Unfortunately you’re dealing with a non-linux type so I have no idea, or even how to read the contents - hence asking how to read the partition with Windows…

If someone would show me the ropes (I can get into command prompt) that would be greatly appreciated.

I also wonder why this has occurred, several colleagues are also suffering this issue and use the PI 2/OSMC in a very similar manor - no stored media, just streaming.

I suspect the’ cache’ is full as the OSMC update fails as it hits the cache…

Your help is appreciated.

Post the output of ls -lah /boot

And probably of:
df -h

The updater will refuse to update with less than 30MB free on /boot - this is a precaution to allow for worst case scenarios. Better to abort the install than to try to install and run completely out of space while installing a kernel. (Which could cause an unbootable system…)

I do belive 201M of logs to be the issue :wink:

I tried to capture all logs as I knew someone here might need them to diagnose, it seems they are the root cause post command line tidy.

Now to work out how to delete in the world of Linux…

Maybe myOMSC GUI would benefit from a log clear feature?

Thanks guys :+1::grin:

Lea rereads post again and realises /boot is FAT32, bonus, plugged the card into a Windows box and could easily delete the huge log file :grin:

Ran My OSMC updater again and voila.

Thanks to all, your assistance has been invaluable.

Roll on OSMC and special thanks to Sam :+1:


In future the command you are looking for is rm

Glad all is well now

For future reference you could have done:

sudo rm /boot/uploadlog.txt

The sudo is needed because the files in /boot are all owned by root so you would not otherwise have permission to delete them.

If your log file was 200MB you were probably running the initial September update that had a mistake that caused lots of debug logging. (Thus massive log files) That problem has since been fixed.